[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Broken Kernel since 2.6.15 - More Info



This is what I see when I boot.


Booting 'Fedora Core (2.6.15-1.2054_FC5)' 

root (hd0,0) 
 Filesystem type is ext2fs, partition type 0x83 
kernel /vmlinux-2.6.15-1.2054_FC5 ro root=/dev/V0/L1 acpi=off rhgb quiet 
      [Linux-bzImage, setup=0x1e00, size=0x16eb71] 
initrd /initrd-2.6.15-1.2054_FC5.img 
     [Linux-initrd @ 0x37e3c000, 0x1b312a bytes] 

Uncompressing Linux... Ok, booting the kernel. 
Red Hat nash version 5.0.32 starting 
ata1: failed to set xfermode, disabled 
ata2: failed to set xfermode, disabled 
device-mapper: dm-mirror: Device lookup failure 
device-mapper: reload ioctl failed: No such device or address 

Unable to open /dev/mapper/via_jheaibjjh - unrecognised disk label. 
   Reading all physical volumes.  This may take a while... 
   No volume groups found 
   Unable to find volume group "V0" 
Unable to access resume device (/dev/V0/L0) 
mount: could not find filesystem '/dev/root' 
setuproot: moving /dev failed: No such file or directory 
setuproot: error mounting /proc: No such file or directory 
setuproot: error mounting /sys: No such file or directory 
switchroot: mount failed: No such file or directory 
Kernel panic - not syncing: Attempted to kill init! 



With kernel 2.6.17-1.2187_FC5 the message is pretty much the same except
for:

ata1: failed to set xfermode (err_mask=0x4) 
ata2: failed to set xfermode (err_mask=0x4)

VIA 8237 
libata version 1.20 
sata_via version 1.1 
/dev/V0/L1 / ext3

A couple of people have suggested running mkinitrd and I have upgraded it
and created new initrd file and it does the same thing.

When I boot from the installation DVD in linux rescue mode it load sata_via
And everything is fine.  Just can't boot off the SATA drive.

Just think I am going to have to figure out how to make a boot cdrom and
load the drivers from it.
Only other thing I can think of doing is building kernel with libata and
sata_via as part of the kernel.
Mkinitrd -v says it is loading about 5 modules and looks like it should
work.


-----Original Message-----
From: fedora-test-list-bounces redhat com
[mailto:fedora-test-list-bounces redhat com] On Behalf Of Jerry Williams
Sent: Tuesday, September 19, 2006 12:11 AM
To: fedora-test-list redhat com
Subject: Broken Kernel since 2.6.15

I was running FC4 and I was running fine until the kernel-2.6.16.
I kept my older kernel-2.6.15 and 2.6.14 which worked just fine.
The newer kernels can't seem to find my SATA disks.
[Bug 187641] kernel-2.6.16-1.2069_FC4 SATA panic
[Bug 199034] SATA -> Failed to set xfermode -> Kernel panic
I received an email saying:
>FC4 has now transitioned to the Fedora legacy project, which will continue
>to
>release security related updates for the kernel.  As this bug is not
>security
>related, it is unlikely to be fixed in an update for FC4, and has been
>migrated
>to FC5.

>Please retest with Fedora Core 5.

>Thank you.


I decided to upgrade to FC5 since it still had a kernel-2.6.15.
Now my system won't boot.
I also tried the latest kernel-2.6.17, same thing.
I feel like fedora has pulled the plug on my system.

The funny thing is that I can boot from the DVD and go into rescue mode and
it finds the drive just fine.

So my question is what do I have to do to make a cdrom that I can boot from
and find my disk and load everything else from disk?

I tried a grub floppy, and that worked, but only for the kernels that worked
without it.  So it didn't buy me anything.

So I think the cdrom has to have the kernel on it.

-- 
fedora-test-list mailing list
fedora-test-list redhat com
To unsubscribe: 
https://www.redhat.com/mailman/listinfo/fedora-test-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]