[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Help with RPM rebuilddb



On Fri, 22 Sep 2006, oldman wrote:

Myles Green wrote:
On Fri, 22 Sep 2006 13:59:12 -0700
oldman <talbotscott cox net> wrote:


Any ideas of a safe way to get rpm and yum working again?


Scott

I ran into this a while back after interrupting yum. My solution was to
delete the rpm db and the re-run rpm --rebuilddb. It Worked For Me(tm),
YMMV and if it breaks you get to keep all the pieces :-)

This is like saying "cd / rm -rf *" DO NOT do either one of these!!

I thought about tying that, but was led astray by errors about the
"Packages" file not being read by db3.  Guess I just over-thought that
one by a mile :-)

DO NOT DELETE THE RPMDB!! It will take you a long time to recreate it!!
rpm --rebuilddb will NOT recreate it. At best it will leave you with an empty
rpmdb.

At that point you will either need to reinstall the system OR spend a lot of
time running rpm --justdb package-name.

The way to correct your problem is to do "rm /var/lib/rpm/__db.00* and then
run rpm --rebuilddb. That will most likely fix your problem.

I have fixed this problem several times with this proceedure. Sometimes it is
sufficient to simply rm the lock files.

Regards,

--
Tom Diehl		tdiehl rogueind com		Spamtrap address mtd123 rogueind com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]