[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Perl won't update



> Installed compat-db-4.5.20-3.fc8 and db4 but still  can't install perl.  Running 
>  yum -y upgrade perl.i386
> leads to the following--
> 
> Running rpm_check_debug
> --> Populating transaction set with selected packages. Please wait.
> ---> Package perl-devel.i386 4:5.8.8-25.fc8 set to be updated
> ---> Package perl.i386 4:5.8.8-25.fc8 set to be updated
> ---> Package perl-Test-Harness.i386 0:2.56-25.fc8 set to be updated
> ---> Package perl-libs.i386 4:5.8.8-25.fc8 set to be updated
> ---> Package perl-Test-Simple.i386 0:0.62-25.fc8 set to be updated
> ERROR with rpm_check_debug vs depsolve:
> Package perl-devel needs perl(ExtUtils::Embed), this is not available.
> Package perl-devel needs perl(ExtUtils::Installed), this is not available.
> Package perl-devel needs perl(ExtUtils::MakeMaker), this is not available.
> Complete!
> 
Noted the responses that there are additional packages that can be installed to resolve the 
issue.
There have been several instances where yum just gives up rather than collecting all the dependencies for a package.  Is this behavior an artifact of the merger of Extras?  Sometimes there is enough information to do a explicit yum install of the missing rpm.  Others like here seem to be
a mystery until one is enlightened.

TNWestTex



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]