[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

info about kernel-2.6.20-1.2925.fc6 and kvm version to use



Hello all,
I updated my fc6 x86_64 system to the kernel in subject, that provides
its own kvm kernel modules.
So I passed from 2.6.19-1.2911.6.5.fc6 to this one.
With the 2.6.19 kernel I compiled and used kvm-12 (from a fedora dev
spec file modified not passing the --with-patched-kernel option in
configure phase), sot that I generated the kvm kernel modules.
I was able with the 2.6.19 to install fc7 t2 x86_64 version from the
dvd iso with qemu-kvm:
I had only a problem with mkinitrd phase ever-lasting, but resolved
killing the parent mkinitrd command and re-running it at the end of
install, before rebooting.
(I don't know if this is related to x86_64 itself in general or only
in my environment).
Now with this 2.6.20 kernel and its own kvm modules I'm able to run
the f7t2 vm (I'm in need to apply 248 updates....since t2) using the
already installed kvm user space programs.
I'm also able to run concurrently f7t2 and a winxp kvm machine created
on the same hardware starting a fc6 32bit system (the hw is dual-boot
fc6 32 and fc6 x86_64).
On kvm download page there is this information:

Note: the modules provided by Linux 2.6.20 require kvm-12. If you use
the external module, use the latest available version.

At the end the question:
is this fedora kernel patched in some way that I can use latest kvm-16
or must I stay with kvm-12? I saw that in fedora devel (ok another
kernel) there is kvm-15...
I presume that in 4 kvm versions there are many improvements/bug fixes.
Apparently in changelog of this kernel I found nothing related to kvm...
The system is a quad core 2.6GHz with 2GB of ram and eventually I
would like to test also xen, but it seems that at this time the 2.6.20
xen kernel is not available.
And also the virt-manager/libvirt packages on fc6 are not the ones
ready for managing also kvm....
Thanks in advance for any hints and suggestions, keeping in mind that
I would like to mantain on the bare hw level the fc6 systems (x86 /
x86_64).
Gianluca


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]