[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20070320 changes(correction)





On 3/21/07, John Poelstra <poelstra redhat com> wrote:
Ronald Warsow said the following on 03/21/2007 08:08 AM Pacific Time:
> Ronald Warsow wrote:
>> Jim Bevier wrote:
>>>
>>> ----- Original Message ----- From: < buildsys redhat com>
>>> To: <fedora-devel-list redhat com>; <fedora-test-list redhat com>
>>> Sent: Tuesday, March 20, 2007 3:10 AM
>>> Subject: rawhide report: 20070320 changes
>>>
>>> [clip]
>>>
>>> The last two kernels 2997 & 2999 no longer allows VMWare to build.
>>> Anybody have a fix?
>>>
>>> Jim
>>
>> can't say something to kernels 2997 & 2999, but for previous:
>>
>> cd /usr/lib/vmware/modules/source/
>> tar xvf vmmon.tar
>> cd vmmon-only/include
>> vi compat_kernel.h
>>
>> line 80:
>> #define __NR_compat_exit __NR_exit
>> +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,19)
>>     static inline _syscall1(int, compat_exit, int, exit_code);
>> -
>> +#endif
>>
>> tar -cf vmmon.tar vmmon-only
>> vmware-config.pl -d
>> ------------------------------------------------------
>
> this advise doesn't work any more !
>
> :\
>
>

I'm seeing the same problem on FC6 and haven't been able to find a fix yet on google.

With VMwareWorkstation-5.5.3-34685 and running the 2.6.20-1.2925.fc6 I cannot rebuild the modules after applying the manual fixes (above) and trying a fresh install of vmware and applying the any-any patch.

I had the same problem on FC6.  Check out http://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=35020&forum=10&post_id=156401

and then run the script in http://ftp.cvut.cz/vmware/vmware-any-any-update108.tar.gz and download and install the new version of VMWare server, 1.0.2.  That worked for me.

Gerry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]