[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ipw3945 not working with kernel 2.6.20-1.2925.fc6



On 3/21/07, Horst H. von Brand <vonbrand inf utfsm cl> wrote:
> > You will have to check with one of the other repositories (freshrpms,
> > etc) for items to get the ipw3945 working. If it was working in the
> > past, but doesnt work now.. then it is probably that the module needs
> > an update from whatever repository you got ipw3945 from.
>
> Looks like there are no updates, drats!!

I think here we are talking about different issues.

AFAICT the original poster is using a ipw3945 driver packaged in kmdl
format from another repo for the regular fc6 kernel. I never used kmdl
stuff, so I can't really help there, though I have to note that issue
is probably to be raised in another list (atrpms-users ?)


Here (rawhide) I when I try to build the module from 1.2.0 sources, the
Fedora kernels give lots of warnings (and the resulting module won't load
at all in the end), while vanilla kernels (from git) work fine.

AFAIK, latest rawhide kernels received the ipw3945 driver (thaks to
John Linville) so it should work OOTB (installing the proper firmware
now in the extras repo).

Please note the driver in rawhide is _not_ the same ipw3945 you tried
to build, but the iwlwifi one (that is, the one without the binary
only regulatory daemon), so chances are your failed build is not
really unexpected...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]