[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum update failure glibc.i686 on Fedora 7 Test 2 x64 yum 3.1.4-1.fc7



On Fri, Mar 23, 2007 at 02:47:20AM -0400, John Hall wrote:
> 
> I ran
> yum -y upgrade glibc and got a file conflict.
> between -17 and -19 versions

That usually means that you have both x86 and x86_64 variants
installed and that a mirror from which you are trying to run
updates has/had different versions for both.  Packages for different
architectures have to be updated "in a lockstep" or you will see
such conflicts.

Metadata should have expired in the meantime anyway but in a case
you got a mess there, due to not entirely healthy mirror you were
trying to get that stuff from, try if 'yum clean metadata' will
straighten things out.

In case you need a glibc update only for x86_64 then running

     yum -y upgrade glibc.x86_64

gives a helpful hand to yum. Also when you know that something
is not entirely healthy then running 'yum -y...' is not so great
idea.

   Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]