[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Adding new raid partitions causes panic on reboot



Test box running kernel-2.6.20-1.3003.fc7

/boot on /dev/sda1
swap on /dev/sdb1
root on /dev/sd[cdef]1 as /dev/md0 raid0

while running I created /dev/sd[abcdef]2 as raid partitions using the
remainder of the disks
the kernel refused to re-read the partition tables, when exiting
fdisk, and also when I tried to force it with blockdev --rereadpt

therefore I couldn't yet do mdadm --create as partitions unknown to
kernel, so I rebooted to allow kernel to see new partitions, then
planned to create array after reboot.

BOOM!

kernel had tried to assemble the new partitions /dev/sd[abcdef]2 as
/dev/md0, then considered adding the existing root array partitions
/dev/sd[cdef]1 to /dev/md0 (and failed as it thought the array was
already running) so it failed to mount root and panicked.

/etc/mdadm.conf contents

DEVICE partitions
MAILADDR root
ARRAY /dev/md0 level=raid0 num-devices=4
uuid=f48da494:15e43bc0:393109de:ad419f81

Why did it snarf assembling my existing array?
What could/should I have done differently?

Thinking about it, before clicking send, from a previous install I had
previously used raid partitions in exactly the same spot on disk as
the /dev/sd[abcdef]2 partitions.

So I presume I should have dd if=/dev/zero of=/dev/sda2 etc before
rebooting to hide the partition contents?

Live and learn new ways to shoot your own foot, I suppose.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]