[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Install gives BSOD on Thinkpad T60p

On Mon, 2007-05-21 at 11:30 -0400, Adam Jackson wrote:
> On Sat, 2007-05-19 at 23:27 -0400, David Kramer wrote:
> > This is my first experience with a testing release, so I apologize if
> > I'm not reporting this right, or not giving enough information.
> > 
> > I just got a Lenovo Thinkpad T60p.  It's got a 15.4" WSXGA+
> > TFT/1680x1050 (16:10) screen driven by a ATI Mobility Fire GL V5250 256MB.
> > 
> > When I attempt a graphical install of F7-test4, after the few initial
> > "Loading..." screens, I get a few flashes with pretty patterns, then the
> > screen turns all blue with no writing, and stays that way indefinitely.
> > 
> > When I attempt a text mode install (the pain! the pain!), the install
> > works, but it doesn't configure X.  When I try to run X, I get a quick
> > screen flash or two, then it kicks me back to the CLI, but now all
> > sessions are 40 characters wide and twice as tall, so I can't edit files
> > or type anything out.  Nothing but a reboot fixes this.  I tried
> > system-config-display, but that exited out, too.  I tried redirecting
> > the output to a file, and I did at one point see a message about not
> > being to get Xinerama info.
> The 40-column syndrome is either the x86 emulator being crap, or ATI's
> VBIOS being crap.  Either way, "vbetool post" should make it go away.
> I don't see the X log from the failed launch on the forum thread you
> mention, so I'm going to hope I can repro this with the T60p I've got
> here.

I can't.  X works fine for me.  I still get the C64-style 40 column mode
on VT switch or server exit, but I'm reasonably convinced now that
that's ATI's VBIOS being junk.  Omitting the extended VBE state
save/restore code from the vesa driver doesn't help.  Neither does
running 'vbetool vbestate save' before X launch and 'vbetool vbestate
restore' after.  I can clearly see that the VBE state is different
between 80 and 40 column modes, but I can't feed that state back into
the card, so, whoopie.

Working on hunting down that crash though.

- ajax

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]