[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

libkeyutils.so not found

After yesterday update my x86_64 machine fails to find libkeyutils.so.1 library.
Many services such as sendmail, rpcbind, cups and sm-client complain about this

Apart from the yum update with the gui puplet the only thing I did
yesterday was to remove, without forcing nothing, some i386 packages
(only "rpm -e " command used).
I don't know if this problem depends on yum update or i386 removal.

there are other problems arised:

- yum failing to start
I tried
[root pevit00 log]# yum install /usr/lib64/libkeyutils.so.1
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

  No module named _sha256

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.5 (r25:51908, Apr 10 2007, 10:27:40)
[GCC 4.1.2 20070403 (Red Hat 4.1.2-8)]

If you cannot solve this problem yourself, please go to
the yum faq at:

In yum.log I have

May 24 10:01:47 Updated: yum-metadata-parser.x86_64 1.1.0-2.fc7
May 24 10:01:49 Updated: yum.noarch 3.2.0-1.fc7
May 24 10:07:42 Updated: yum-updatesd.noarch 3.2.0-1.fc7
May 24 10:07:46 Updated: yum-fastestmirror.noarch 1.1.4-1.fc7

- Init level 5 fails to start. The screen remains at the blue circle
with black background, without arriving at gdm login screen

with ps -ef it seems that I have  the process /bin/sh /etc/gdm/Init/Default
ciclically trying to start.... see below

root      2486  2481  5 08:41 tty7     00:00:04 /usr/bin/Xorg :0 -br
-audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
root      6863  2401  0 08:41 tty1     00:00:00 -bash
root     15904  2481  0 08:42 ?        00:00:00 /bin/sh /etc/gdm/Init/Default
root     15905  6863  0 08:42 tty1     00:00:00 ps -ef
root     15906  6863  0 08:42 tty1     00:00:00 -bash
root     15907 15904  0 08:42 ?        00:00:00 xrdb -merge /etc/X11/Xresources

root      2407     1  0 08:40 ?        00:00:00 /usr/sbin/gdm-binary -nodaemon
root      2481  2407  8 08:41 ?        00:00:20 /usr/sbin/gdm-binary -nodaemon
root      2485     1  0 08:41 ?        00:00:00 /usr/sbin/gdm-binary -nodaemon
root      2486  2481  3 08:41 tty7     00:00:09 /usr/bin/Xorg :0 -br
-audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
root      6863  2401  0 08:41 tty1     00:00:00 -bash
root      7544  2481  0 08:45 ?        00:00:00 /bin/sh /etc/gdm/Init/Default
root      7548  6863  0 08:45 tty1     00:00:00 ps -ef

- before update I used intel driver in xorg.conf. now I tried both
with it and with the i810 but no difference.

I tried both latest kernel and the 3116 one but no difference

in dmesg I have these:

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)

Call Trace:
[<ffffffff8022a34e>] local_bh_enable+0x42/0x98
[<ffffffff8025c08d>] cond_resched_softirq+0x35/0x4b
[<ffffffff8022ef57>] release_sock+0x65/0xba
[<ffffffff802256ee>] tcp_sendmsg+0x992/0xa9c
[<ffffffff802430c6>] sock_aio_write+0x110/0x128
[<ffffffff80242fb6>] sock_aio_write+0x0/0x128
[<ffffffff802cd935>] do_sync_readv_writev+0xc0/0x107
[<ffffffff80293441>] autoremove_wake_function+0x0/0x2e
[<ffffffff8020c85c>] do_sync_read+0xc9/0x10c
[<ffffffff8025de5d>] error_exit+0x0/0x84
[<ffffffff802cd805>] rw_copy_check_uvector+0x6c/0xdc
[<ffffffff802cdda6>] do_readv_writev+0xd7/0x1ae
[<ffffffff8025beb5>] thread_return+0x5e/0xfd
[<ffffffff802cdf04>] sys_writev+0x45/0x93
[<ffffffff8025711e>] system_call+0x7e/0x83

eth0: no IPv6 routers present
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized i915 1.6.0 20060119 on minor 0

Any hints on what to do?
Are these three problems actually different faces of the same one
(missing of libkeyutils.so.1)?
In which package can I find the shared library... as I cannot use yum
to search..?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]