[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing kdelibs-*.4.1 in updates-testing.



2008/8/4 Adam Pribyl <pribyl lowlevel cz>:
>> yum install --enablerepo=updates-testing kde*-devel*4.1*.x86_64
>
> It's probably not the fix for your problem, but IMHO the syntax is
> incorrect. Those * will be expanded by shell. You should use escapes \* if
> you want those to get to yum.

Actually, not quite. *If* there is something in the current directory
that matches, then the shell will expand the wildcard; but if there's
nothing that matches the pattern (which, with a pattern like the
above, is probably the expected case), then the "*" version somehow
magically makes it to yum after all. As long as you're running bash,
at least -- not sure if this works in tcsh as well.

Important Note: although it's convenient, it can be dangerous to rely
on the above wildcard trick. I spent much more time than I should have
last week trying to figure out why "yum list openoffice.org*" kept
returning "no matching packages" ... until I realised I actually had a
directory that matched that wild-card. Whoops. :)

MEF

-- 
Mary Ellen Foster -- http://homepages.inf.ed.ac.uk/mef/
Informatik 6: Robotics and Embedded Systems, Technische Universität München
and ICCS, School of Informatics, University of Edinburgh


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]