[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

muine dependancy



Why doess muine up to 0.8.8-4 no longer provide mono(muine-plugin) but still
have this as a dependancy?
I would think that if the software no longer provides a certain aspect of
functionality that it once did then the dependancy should be dropped as
well.
I built the latest package from scr.rpm and here's what happens when you try
to install the packages

+ exit 0
Provides: config(muine) = 0.8.8-6.fc9 libinotifyglue.so.0 libmuine.so.0
Requires(interp): /bin/sh /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(pre): /bin/sh GConf2
Requires(post): /bin/sh GConf2 desktop-file-utils
Requires(preun): /bin/sh GConf2
Requires(postun): /bin/sh desktop-file-utils
Requires: /bin/bash config(muine) = 0.8.8-6.fc9 gtk-sharp2 libFLAC.so.8
libatk-1.0.so.0 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
libcairo.so.2 libdl.so.2 libgconf-2.so.4 libgdbm.so.2 libgdk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0 libglib-2.0.so.0 libgmodule-2.0.so.0
libgnomevfs-2.so.0 libgobject-2.0.so.0 libgstreamer-0.10.so.0
libgthread-2.0.so.0 libgtk-x11-2.0.so.0 libid3tag.so.0 libinotifyglue.so.0
libm.so.6 libm.so.6(GLIBC_2.0) libmuine.so.0 libogg.so.0 libpango-1.0.so.0
libpangocairo-1.0.so.0 libpthread.so.0 librt.so.1 libvorbis.so.0
libvorbisfile.so.3 libxml2.so.2 libz.so.1 mono(Mono.Posix) = 2.0.0.0
mono(gdk-sharp) = 2.10.0.0 mono(glib-sharp) = 2.10.0.0 mono(gtk-sharp) =
2.10.0.0 mono(mscorlib) = 2.0.0.0 mono(muine-plugin) = 1.0.0.0 mono-core
mono-web rtld(GNU_HASH)
Processing files: muine-devel-0.8.8-6.fc9
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: muine = 0.8.8
Wrote: /home/gjohnson/rpmbuild/RPMS/i386/muine-0.8.8-6.fc9.i386.rpm
Wrote: /home/gjohnson/rpmbuild/RPMS/i386/muine-devel-0.8.8-6.fc9.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.28621
+ umask 022
+ cd /home/gjohnson/rpmbuild/BUILD
+ cd muine-0.8.8
+ rm -rf /var/tmp/muine-0.8.8-6.fc9-root-gjohnson
+ exit 0
Executing(--clean): /bin/sh -e /var/tmp/rpm-tmp.28621
+ umask 022
+ cd /home/gjohnson/rpmbuild/BUILD
+ rm -rf muine-0.8.8
+ exit 0
[gjohnson localhost ~]$ su -c 'rpm -Uvh
/home/gjohnson/rpmbuild/RPMS/i386/muine-0.8.8-6.fc9.i386.rpm
/home/gjohnson/rpmbuild/RPMS/i386/muine-devel-0.8.8-6.fc9.i386.rpm'
Password: 
error: Failed dependencies:
	mono(muine-plugin) = 1.0.0.0 is needed by muine-0.8.8-6.fc9.i386

Seems like this is broken

-- 
View this message in context: http://www.nabble.com/muine-dependancy-tp15078811p15078811.html
Sent from the Fedora Test List mailing list archive at Nabble.com.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]