[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Still having firefox problems



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Alan wrote:
> I have something munged up and I am not certain how to fix it other than a
> reinstall when the beta comes out.
> 
> When I try and run firefox from a shell I get the error:
> 
> Error: Platform version '1.9b4pre' is not compatible with
> minVersion >= 1.9b5pre
> maxVersion <= 1.9b5pre

Check what versions of firefox you now have installed:

rpm -q firefox

When I hit this, I found I had 3 separate versions in the RPM db (due to
earlier update failures because of the xulrunner directory-to-symlink
change which has already been discussed at length on this list).

Remove all of these packages - rpm -e or yum remove should work fine,
although you may need to use --noscripts here as one of the package
triggers was failing (using rm instead of rm -f to delete a file that
did not exist) for me.

Then re-install xulrunner making sure that it completed correctly
without any cpio errors and then you can re-install firefox.

Regards,
Bryn.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iD8DBQFH2A8C6YSQoMYUY94RAskiAJsGMRAcBGo4EfNhFMaNBrT0JA5ZTQCeK5s5
fPIfPboojmmLvahMv/Df/fQ=
=jGyd
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]