[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F8 -> F9 preupgrade



Klaasjan Brand írta:
2008/5/14 Zoltan Boszormenyi <zboszor freemail hu <mailto:zboszor freemail hu>>:

    Hi,

    I tried preupgrade without success, but at least it didn't destroy
    my old installation. :-)

    I started package downloads with preupgrade 0.9.3-1, then killed it
    when 0.9.3-2 came out, upgraded and continued downloading.
    Total download size was about 6.2 GB, I have many huge games
    installed from Fedora 8 Everything. However, this version hung
    at the last download phase, which was fixed by 0.9.3-3.


I think it has something to do with preupgrade looking for a ".treeinfo" file, which wasn't available on my mirror. I've fixed it by pointing the preupgrade configuration to a mirrorsite that had the treeinfo file.

    This version offered to reboot into upgrade finally, which I did.
    It booted into anaconda upgrade, which detected my partitions
    correctly.
    The problem that made the upgrade unsuccessful was that Anaconda
    doesn't pull the network settings from my old installation and I have
    an ADSL connection with a dump ADSL modem, not a router.


Does anaconda need an internet connection after preupgrade has downloaded all the relevant files for your upgrade?

What else would the "Retrying package download" message indicate?
I have many packages installed from both Fedora Everything and Livna.

Another small bug I've found which could be handled better is that the kernel from Fedora 9 swapped my sda and sdb disks (I've got a SATA and an IDE disk in my system), and anaconda isn't able to find the stage2 image (there's a prompt asking for the correct disk, but none of the options work).

Kj






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]