[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Unable to update Rawhide



On Sun, 5 Apr 2009, Adam Huffman wrote:

On Sun, Apr 05, 2009 at 01:02:15PM +0300, Aioanei Rares wrote:
I have updated my rawhide frequently, but I can't update rpm, because of
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : rpm-libs                                                 1/8
Error unpacking rpm package rpm-libs-4.7.0-0.beta1.9.fc11.x86_64
warning: rpm-libs-4.7.0-0.beta1.9.fc11.x86_64: Header SHA1 digest: NOKEY
error: unpacking of archive failed on file
/usr/lib64/librpm.so.0.0.0;49d88160:cpio: MD5 sum mismatch
  Updating       : rpm                                                      2/8
Error unpacking rpm package rpm-4.7.0-0.beta1.9.fc11.x86_64
warning: rpm-4.7.0-0.beta1.9.fc11.x86_64: Header SHA1 digest: NOKEY
                                             ^^^^^^^^^^^^^^^^^^^^^^^^^
That's a kinda "can't happen" message, SHA1 header digest check is failing before it even gets to actually comparing the hashes. The file digest failures in this case are likely to be symptoms of the same core issue (whatever it is)

Yes, exactly the same for me.  Running rpm directly on the downloaded
files has the same result.

Can you check what 'rpm -Kvv' on the packages say? And if you have some other, non-rawhide system you can try it on, what does signature checking on these same failing packages say there?

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]