[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No i386 images in rawhide,



On Mon, 6 Apr 2009, Jesse Keating wrote:

On Mon, 2009-04-06 at 19:33 +0300, Panu Matilainen wrote:

Details please? Actual rpmdb *corruption* is rare, it's almost always
something else. "Last couple of days" sounds like it could be the
related to the NSS caused breakage.

When on an x86_64 system and trying to compose an i386 install tree, the
buildinstall process falls over when trying to compose the image due to
what looks like rpmdb corruption, but could be something else.  Note
that we explicitly rm -f the /var/lib/rpm/__db* files before running
pungi (buildinstall).  I am not able to reproduce outside our build
environment, and even outside this particular host, yet.  Still
investigating.

http://kojipkgs.fedoraproject.org/mash/rawhide-20090403/logs/i386.log

i386 on x86_64 borking could easily fit the recent NSS thingie, which is exactly a multilib issue (bug 494122, nss-softokn-freebl getting pulled in for just one, possibly wrong arch on multilib systems). See if it goes away with nss-3.12.2.99.3-7.

The errors look like memory corruption of sorts (garbled/truncated macro strings), if that goes away by updating NSS then it's probably some path(s) not correctly checking for failures from NSS (there are probably plenty) and tripping up something else in turn.

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]