[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No i386 images in rawhide,



>> I'm getting that exact error on a Fit-PC machine (AMD Geode of similar
>> spec to the OLPC) that's running Fedora 10. I went to upgrade it on
>> the weekend to F11 beta. As part of the yum upgrade I did a "yum
>> upgrade rpm yum" which of course pulled in python. The geode is
>> capable of cmov so it has a i686 glibc installed (but it complains
>> about the arch) so rather than installing the i386 F10 glibc so it
>> would go smoothly I used rpm to install the F11 i586 glibc package.
>> Everything runs fine but I get the same errors with rpm so its stuck
>> in that state at the moment. I went to do a clean install of F11 but X
>> fell over (which worked on F10 install) so I haven't bothered to go
>> any further if you want me to run some tests.
>
> Hmm, Geode doesn't fit the NSS-case as it's not multilib. Please post the
> exact errors you're seeing and the command that produced it. Also, does rpm
> itself work (ie is it just yum that's busted) and if not, what errors you
> get from that?

Its just plain rpm. An example doing a simple package query gives me
the following

[root cypher ~]# rpm -q glibc
error: Unterminated {: {_%{_keyringpath}/*.k
  0< /
error: /: reading of public key failed.
error: cannot open Packages index using db3 - No such file or directory (2)
error: Unterminated {: {_%{_dbpat�
  0< /
error: cannot open Packages database in /
package glibc is not installed
[root cypher ~]#

Let me know if you want me to do further testing.

Peter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]