[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No i386 images in rawhide,



>>>>>>>> Its just plain rpm. An example doing a simple package query gives me
>>>>>>>> the following
>>>>>>>>
>>>>>>>> [root cypher ~]# rpm -q glibc
>>>>>>>> error: Unterminated {: {_%{_keyringpath}/*.k
>>>>>>>>  0< /
>>>>>>>> error: /: reading of public key failed.
>>>>>>>> error: cannot open Packages index using db3 - No such file or
>>>>>>>> directory
>>>>>>>> (2)
>>>>>>>> error: Unterminated {: {_%{_dbpat???
>>>>>>>>  0< /
>>>>>>>> error: cannot open Packages database in /
>>>>>>>> package glibc is not installed
>>>>>>>> [root cypher ~]#
>>>>>>>>
>>>>>>>> Let me know if you want me to do further testing.
>>>>>>>
>>>>>>> Smells strongly of memory corruption... Can you run the same with
>>>>>>> valgrind?
>>>>>>>
>>>>>>> # valgrind --leak-check=yes rpm -q glibc
>>>>>>
>>>>>> Hmm. don't have valgrind installed and rpm is screwed so I can't.....
>>>>>> suggestions?
>>>>>
>>>>> rpm2cpio should work even if rpm is otherwise screwed (and if even that
>>>>> fails, there's a script version in /usr/lib/rpm/rpm2cpio.sh). Also just
>>>>> a
>>>>> strace might provide some clues, if you have that installed.
>>>>
>>>> Any idea what provides the memcheck tool?
>>>>
>>>> [root cypher bin]# ./valgrind --leak-check=yes rpm -q glibc
>>>> valgrind: failed to start tool 'memcheck' for platform 'x86-linux': No
>>>> such file or directory
>>>> [root cypher bin]#
>>>
>>> valgrind expects to find the bits and pieces in certain places - you'll
>>> need
>>> to do the rpm2cpio unpacking from / to get the paths right.
>>
>> Output can be found here. Let me know if you want any other things run.
>>
>> http://pbrobinson.fedorapeople.org/rpm-valgrind.txt
>
> Hmm, this appears to be F10 valgrind (==3619== Using valgrind-3.3.0), which
> is fairly broken at least as far as rpm goes (it doesn't handle pipe2()
> syscall which prevents macros from getting properly processed), try grabbing
> rawhide valgrind instead and rerun.
>
> Some related items: despite macros being somewhat busted, it actually
> manages to return the glibc version: glibc-2.9.90-12.i586. That is rawhide
> alright, but then:
>
> ==3623==    by 0xBAB7C3: rpmInitCrypto (in /usr/lib/librpmio-4.6.so)
>
> ...it still has rpm 4.6.0, whereas rawhide has 4.7.0-beta1. That this
> happens with rpm 4.6.0 too is probably a useful piece of information.
> Since rpm seems to limp on somehow under valgrind (which is might be a clue
> in itself), try grabbing the entire package list with 'valgrind rpm -qa',
> maybe there are some further clues there. (and yes this is pretty much
> shooting in the dark, trying to hunt for some clues)

Basically the only thing on the box that's rawhide is glibc which is
about where it got to before it barfed. If you contact me off list I
can give you a login to the device to investigate if you like.

Peter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]