[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: having installed with simple video driver, can't get 1280x800 back



On Fri, 10 Apr 2009, François Cami wrote:

> On Fri, 10 Apr 2009 05:57:35 -0400 (EDT)
> "Robert P. J. Day" <rpjday crashcourse ca> wrote:
>
> >   following up on an earlier post, the only way i could install f11
> > beta on a new gateway m-1626 with a 1280x800 display and a radeon
> > xpress 1270 video chipset was to select "simple video driver."
> >
> > is there a graphical way to adjust this, or should
> > i fix this by manually editing xorg.conf?
>
> 0. patch your system up to kernel-2.6.29.1-54.fc11 and
>   xorg-x11-drv-ati-6.12.1-10.fc11 . Those are available from koji :
>   http://koji.fedoraproject.org/koji/buildinfo?buildID=97202
>   http://koji.fedoraproject.org/koji/buildinfo?buildID=96839
> 1. rename xorg.conf to xorg.conf-backup
> 2. check grub.conf for "nomodeset" and remove it as needed (a backup
>   of the original grub.conf is advisable as well)
> 3. reboot.
>
> You should be using the radeon driver in KMS mode.
>
> If that fails, boot without KMS (add nomodeset to the kernel command
> line). If that still fails, boot into runlevel 3 (add 3 to the
> kernel command line) and switch back grub.conf and xorg.conf to the
> original state.

  done all that, no change.  i first rebooted with the new ati driver,
didn't help.  i rebooted and manually added "nomodeset" to the kernel
command line (and verified it was there via /proc/cmdline), no
difference.  then rebooted normally again, still no change -- stuck at
1024x768.

  this is the relevant snippet from dmesg from that last reboot:
=====
[drm] Initialized drm 1.1.0 20060810
radeon 0000:01:05.0: power state changed by ACPI to D0
radeon 0000:01:05.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
ATOM BIOS: ATI Radeon Xpress for SA1A

[drm] Detected VRAM RAM=131072K, accessible=131072K, BAR=131072K
reserve_memtype: calling reserve_ram_pages_type for 0xd7900000 0xd7980000 16
i2c-adapter i2c-0: unable to read EDID block.
radeon 0000:01:05.0: VGA-1: no EDID data
i2c-adapter i2c-1: unable to read EDID block.
radeon 0000:01:05.0: LVDS-1: no EDID data
i2c-adapter i2c-2: unable to read EDID block.
radeon 0000:01:05.0: HDMI Type A-1: no EDID data
i2c-adapter i2c-1: unable to read EDID block.
radeon 0000:01:05.0: LVDS-1: no EDID data
allocated ffff88011d511000 1280x800 fb: 0x00040000, bo ffff88011ed04a80
Console: switching to colour frame buffer device 160x50
=====

rday
--

========================================================================
Robert P. J. Day                               Waterloo, Ontario, CANADA

        Linux Consulting, Training and Annoying Kernel Pedantry.

Web page:                                          http://crashcourse.ca
Linked In:                             http://www.linkedin.com/in/rpjday
Twitter:                                       http://twitter.com/rpjday
========================================================================

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]