[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: weirdness going from runlevel 5 to 3



Hello Robert,

On Sat, 11 Apr 2009 06:24:46 -0400 (EDT)
"Robert P. J. Day" <rpjday crashcourse ca> wrote:

> 
>   for debugging purposes (hi, francois!), i wanted to drop out of my
> GNOME desktop to the command line in runlevel 3.  the first time i
> tried that ("init 3"), the whole display went dark and i couldn't find
> anything on any virtual console.  eventually, i powered down and up
> again just to get my system back.
> 
>   i just tried "init 3" again from the desktop and my GNOME session is
> still chugging along happily even though:
> 
> # runlevel
> 5 3
> #

What happens if you :

* add the DontZap option to your xorg.conf :

Section "ServerFlags"
	Option "DontZap" "false"
EndSection

* reboot normally, log on to GNOME

* try "init 3" again

* use CTRL+ALT+BACKSPACE to kill Xorg ?

Several of my programs decided to hang instead of exiting properly
this morning, killing them worked (but is no solution). I'm wondering
if you're not seeing the same problem in different form.

François



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]