[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: weirdness going from runlevel 5 to 3



On Sat, 11 Apr 2009, François Cami wrote:

>
> Hello Robert,
>
> On Sat, 11 Apr 2009 06:24:46 -0400 (EDT)
> "Robert P. J. Day" <rpjday crashcourse ca> wrote:
>
> >
> >   for debugging purposes (hi, francois!), i wanted to drop out of my
> > GNOME desktop to the command line in runlevel 3.  the first time i
> > tried that ("init 3"), the whole display went dark and i couldn't find
> > anything on any virtual console.  eventually, i powered down and up
> > again just to get my system back.
> >
> >   i just tried "init 3" again from the desktop and my GNOME session is
> > still chugging along happily even though:
> >
> > # runlevel
> > 5 3
> > #
>
> What happens if you :
>
> * add the DontZap option to your xorg.conf :
>
> Section "ServerFlags"
> 	Option "DontZap" "false"
> EndSection

  i lied, i had time to test this, and it seems to solve the problem.
"init 3" now takes me properly to runlevel 3, where i can log in as
root and "init 5" gets me back to GNOME so we're good.  and on that
note, i'm out of here for the day.  thanks for all the assistance.

rday
--

p.s.  just to summarize all of the X stuff since yesterday, this is my
xorg.conf at the moment on my gateway m-1626:

  Section "ServerFlags"
        Option "DontZap" "false"
  EndSection

  Section "Device"
	Identifier "Videocard0"
	Driver "radeon"
  EndSection

and i have "nomodeset" in my grub.conf.

========================================================================
Robert P. J. Day                               Waterloo, Ontario, CANADA

        Linux Consulting, Training and Annoying Kernel Pedantry.

Web page:                                          http://crashcourse.ca
Linked In:                             http://www.linkedin.com/in/rpjday
Twitter:                                       http://twitter.com/rpjday
========================================================================

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]