[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: weirdness going from runlevel 5 to 3



Allen Kistler wrote:
"Robert P. J. Day" <rpjday crashcourse ca> wrote:

  for debugging purposes (hi, francois!), i wanted to drop out of my
GNOME desktop to the command line in runlevel 3.  the first time i
tried that ("init 3"), the whole display went dark and i couldn't find
anything on any virtual console.  eventually, i powered down and up
again just to get my system back.

  i just tried "init 3" again from the desktop and my GNOME session is
still chugging along happily even though:

# runlevel
5 3
#

[snip] I think I saw this same trouble as failure to shut down or reboot yesterday. I thought I saw the rc0 script getting killed before the machine had shutdown. That is, the process that's supposed to kill all the other processes got killed. At least that's how I interpret the following log:

[snip]

Leaving me with a blank desktop and a mouse, but nothing else, which is mostly the effect I saw yesterday. The power button is set up to shut down, so that's how I can ultimately shut down.

I'll look for filed bugs and file one myself if I don't see any.

I created BZ #495326 against initscripts.

I haven't tried going from runlevel 5 to runlevel 3 myself, but if you see similar stuff in your logs about rc3 (probably) killing itself off, then maybe its the same bug for real. Alternatively, maybe if your logs show something different, it still is the same bug and the info will help narrow down exactly where things go wrong.

Hey, Triagers:  Good candidate for F11Blocker?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]