[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora-10 nightmare-Update



Hi,

--- On Wed, 4/15/09, François Cami <fcami fedoraproject org> wrote:

> From: François Cami <fcami fedoraproject org>
> Subject: Re: Fedora-10 nightmare-5
> To: "For testers of Fedora Core development releases" <fedora-test-list redhat com>
> Cc: achrisjo yahoo com
> Date: Wednesday, April 15, 2009, 12:10 PM
> On Wed, 15 Apr 2009 01:02:20 -0700 (PDT)
> "Arne Chr. Jorgensen" <achrisjo yahoo com>
> wrote:
> 
> > I would be very pleased
> > in anyone would bother to mention the issue to Xorg,
> and such, as it is
> > I think it clear where the error may be located. I
> have worked around
> > the clock, and it is such a painstaking thing to just
> write anything at
> > all on this machine on the momenent. I would
> appreachiate if some passed
> > this to those that could be able to look into the
> code.
> 
> Arne,
> 
> I realize you're on F10, but the workarounds (nomodeset
> in the kernel
> command line, and switching to XAA in xorg.conf) mentioned
> in the rawhide
> bug https://bugzilla.redhat.com/show_bug.cgi?id=495454 may
> help you.
> 
> Alternatively, I would suggest trying F11 as soon as
> Preview is out and
> reporting any bug at https://bugzilla.redhat.com/ .
> 
> François

Tried F11 despite some errors. But some LVM trouble broke the install.

Thanks for the bugzilla link. Not only Gimp, but a whole bunch of programs
behaved like this. 

My input on the list was an attempt to report what was taking place, as I never thought I would be given the chance again. If I had any machine available, I would never have taken the ordeal to even write a word with the machine. It was a painstaking task. 

Guess what ?  I am using the same machine and now it is somehow behaving
almost satisfactory. Configured to have it boot up with wireless enabled,
and removed cable.  Some noise and glitches on the screen, but I have not
had the same errors. 

Not familiar with the XAA and will have to do some research.

                   ----------------------

Read some interesting discussion about yum, which caused this upgrade from
Fedora 8. ( skipped any disk-install of F9 as it had the same kernel/apic errors ) Interesting to watch that there is an exception for this particular
machine in the new kernel. 

Yum removed some files that no longer exist in the reposities, and I was not
able to rebuild many programs that became useless because of non-existing
libraries. A "black-list" could perhaps be something for yum. If you notify
something in a "yum-blacklist", - library or dependencies you want to keep
because you are using those. ( perhaps the option exist ? - but it is no fun to see your work gone, because of some update and dependencies you have missed spotting ) 

I had not done any upgrade on this particular machine just now, if yum didn't mess it up. 

                   ----------------------
--- On Wed, 4/15/09, Ignacio Vazquez-Abrams <ivazqueznet gmail com> wrote:

> Date: Wed, 15 Apr 2009 03:32:34 -0400
> From: Ignacio Vazquez-Abrams <ivazqueznet gmail com>
> Subject: Re: Fedora-10 nightmare
> To: For testers of Fedora Core development releases
>    <fedora-test-list redhat com>
> Message-ID: <1239780754 3744 58 camel ignacio lan>
> Content-Type: text/plain; charset="us-ascii"
>
> > On Tue, 2009-04-14 at 23:30 -0700, Arne Chr. Jorgensen wrote:
> > It is totally useless on this hardware. HP Compac 6715b.
> >
> > 1. xorg.conf is missing, but attempting to make one never made it recognize
> > 'SHMConfig' 'true', which is very important in this case.
> >
> > 2. Perhaps it is not meant to use xorg.conf ? Found some notes about setting
> > things in HAL ?  And the software is probing the screen in a clever way, as
> > it looks to my. Generation of the xorg.conf was done by "xorg -configure :1"
> > and attempt to make an entry for synaptics touchpad was tried.
> > Question: - is it meant to use an xorg.conf or should something be set in
> > some HAL files instead ?
>
> cd /etc/hal/fdi/information
> wget http://ivazquez.fedorapeople.org/files/synaptics.fdi
> (modify file to taste)
> service haldaemon restart
> (relog X)
>
> > - strange, as it is coming and going somewhat - now it didn't take a whole
> > day for firefox to get page. The touchpad behaves somewhat, and so on.
> > Then other times, all you can do is power off when everything is stuck.
>
> That sounds too bizarre (and unique) to be strictly a software issue;
> perhaps try updating your BIOS.
>
> -- 
> Ignacio Vazquez-Abrams <ivazqueznet gmail com>
>

Removed xorg.conf and went along with your suggestion. It is what I am running
right now. 

Possible to clarify what this will do ?  
( wonder a bit as it seem like the X-server probing feature may have errors )


You are right about the bizarre stuff. Microsoft only got some of the things
working a couple of months back. And some hardware have only appeared in 
kernel-2.6.27.21-170.2.56.fc10.x86_64. The kernel issues and cpu-core handling
is finally dealt with, it seems. Perhaps this hardware nightmare will come to a closure. 

( didn't expect to have it running like this today at all, and it is the first
time it actually is running Linux with most hardware enabled ! ;)  - the thing
I miss is some explanation of this transformation. There must have been some
hw-registers & BIOS stuff going on, despite 20 or more shutdowns/restarts.

( the CPU scaling and temperatures is looking much, much better ! This used to
run real hot. ) 

- but is it not possible to mount LVMs ? ( have the old drive in a USB caddy, but
cannot access the LVMs )


//ARNE

- sorry, but after a couple of years with trouble... other distro's would not work, and as I said, Microsoft have battled with it too, and some of their stuff is still not working. ( if the noise/flicker on the screen would go away, then this is looking great )
 
  


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]