[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum update: Fatal error, run database recovery ??



On Fri, 17 Apr 2009, sean darcy wrote:

Jerry Amundson wrote:
On Fri, Apr 17, 2009 at 5:21 PM, Rahul Sundaram
<sundaram fedoraproject org> wrote:
On 04/18/2009 03:42 AM, Jerry Amundson wrote:
I'll file a bug, but how can I fix this in the meantime?
Reboot? Odd, I know, but I've had to on occasions where updates put
libraries in confused states.
It might also work because /etc/rc.sysinit has

"rm -f /var/lib/rpm/__db* &> /dev/null"

Heh, that's more likely. I still get get windows-on-the-brain sometimes...

jerry

Rebooting worked. I'm using ext4. Some googling says that's the issue.

No, the issue is that rpm died while in middle of Berkeley DB call which is something that obviously should not happen and this is a situation which doesn't get automatically cleaned up, so you need manual 'rm -f /var/lib/rpm/__*' to continue.

What made rpm die in this manner is another question, and typically pretty much impossible to figure out afterwards. Basically it either crashed or was kill -9'ed while in middle of operating on rpmdb. Filesystem bugs can/will certainly make rpm(db) blow up in dramatic ways, and there was some indication that early ext4 made rpm unhappy but haven't seen any "evidence" of ext4 being more problematic than ext3 recently. At some point (but fixed since AFAIK) canceling searches in PackageKit could trigger this due to using kill -9 on the backend.

You might want to check logs for segfaults from yum, rpm and related pieces. If there's nothing there... impossible to say.

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]