[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Grub trouble testing Fedora 11 snapshot 1 using liveusb-creator



On Fri, Apr 24, 2009 at 06:25:53AM -0400, Christopher Beland wrote:
> I tried "yum --enablerepo=rawhide update syslinux" on Fedora 9, and I
> get this:
> 
> Running rpm_check_debug
> ERROR with rpm_check_debug vs depsolve:
> rpmlib(FileDigests) is needed by syslinux-3.75-1.fc11.i586
....
> 
> Is there any feasible workaround for Fedora 9 while we're waiting for a
> fix to the underlying liveusb-creator bug:

Try

    yumdowloader --enablerepo=rawhide --source syslinux
    rpm2cpio ../SRPMS/syslinux-3.75-1.fc11.src.rpm | \
         (cd $(rpm --eval %{_sourcedir}) && cpio -imd)
    rpmbuild -ba $(rpm --eval %{_sourcedir})/syslinux.spec    

(assuming, of course, that you have relevant pieces of a build chain
installed and you need in this nasm).  Install a resulting package for F9.

I just tried that and it works without any fuss.  A mess with rpm2cpio,
instead of a simple 'rpmbuild --rebuild syslinux-3.75-1.fc11.src.rpm',
is caused by an inability of F9 rpm to unpack rpm packages from F11.
You will get "cpio: MD5 sum mismatch" erorr and it does not seem to
be a way to prevent that.  Nasty!

   Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]