[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: no display after pre-upgrade from F10 to Rawhide



On Mon, 2009-06-08 at 11:40 -0400, Bill McGonigle wrote:
> On 06/07/2009 07:22 PM, Claude Jones wrote:
> > I had a functioning F10 and decided to pre-upgrade to Rawhide/F11. It
> > worked somewhat, but I'm left with one major problem. I can't get x to start
> 
> I had a similar problem with radeon hardware too.  AFAIK, we don't have 
> a discreet database of hardware and driver support so we can't really 
> upgrade somebody without risk of breaking their hardware:
> 
>    https://bugzilla.redhat.com/show_bug.cgi?id=502276
> 
> and with the flux in drivers these days, it's not a small chance.
> 
> I suspect that some future statistical analysis of smolt reports could 
> create such a database.

Fedora intentionally doesn't have one, as it duplicates work done by
X.org (device / driver detection is done in the X server). We also try
to avoid writing too much of a lengthy and complex driver blacklist in
favour of just fixing the damn drivers, but I believe Claude may
actually be using a card that's blacklisted already - there's a series
of GeForce cards that we know don't work with nouveau which are
blacklisted to use nv instead, I think he may have one of those. 'lspci
-nn' would tell us for sure (as a general public announcement, please
give the output of 'lspci -nn' rather than just 'lspci', because plain
lspci doesn't give you the PCI IDs, which are what you really need to
identify a card).

Claude, can you confirm whether it's the 'nouveau' driver or 'nv' which
is used if you start with no xorg.conf ?
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org
http://www.happyassassin.net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]