[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

the current state of trying to "yum update"



not sure if anyone will find the following informative, but i'll just post the current state of affairs.

# yum update
Loaded plugins: dellsysidplugin2, downloadonly, refresh-packagekit
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
... much deleted ...
--> Finished Dependency Resolution
ant-apache-log4j-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-apache-log4j-1.7.1-8.2.fc11.i386 (installed)
ant-apache-bcel-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-apache-bcel-1.7.1-8.2.fc11.i386 (installed)
ant-swing-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-swing-1.7.1-8.2.fc11.i386 (installed)
jdepend-demo-2.6-7.4.fc10.i386 from installed has depsolving problems
--> Missing Dependency: jdepend = 2.6-7.4.fc10 is needed by package jdepend-demo-2.6-7.4.fc10.i386 (installed)
ant-jsch-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-jsch-1.7.1-8.2.fc11.i386 (installed)
ant-commons-net-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-commons-net-1.7.1-8.2.fc11.i386 (installed)
ant-apache-bsf-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-apache-bsf-1.7.1-8.2.fc11.i386 (installed)
ant-jdepend-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-jdepend-1.7.1-8.2.fc11.i386 (installed)
1:eclipse-pde-3.4.1-14.fc11.i386 from installed has depsolving problems
--> Missing Dependency: eclipse-jdt = 1:3.4.1-14.fc11 is needed by package 1:eclipse-pde-3.4.1-14.fc11.i386 (installed)
ant-nodeps-1.7.1-8.2.fc11.i386 from installed has depsolving problems
--> Missing Dependency: ant = 1.7.1-8.2.fc11 is needed by package ant-nodeps-1.7.1-8.2.fc11.i386 (installed)
1:eclipse-pde-3.4.1-14.fc11.i386 from installed has depsolving problems
--> Missing Dependency: eclipse-platform = 1:3.4.1-14.fc11 is needed by package 1:eclipse-pde-3.4.1-14.fc11.i386 (installed)
junit-demo-3.8.2-4.4.fc10.i386 from installed has depsolving problems
... lots more like this...

  ok, let's try and complete that outstanding transaction:

# yum-complete-transaction
Loaded plugins: dellsysidplugin2, refresh-packagekit
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 1415 elements left to run
... lots deleted ...
Transaction Summary
============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove    1539 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
gnome-games is needed by (installed) gnome-games-help-1:2.25.92-1.fc11.noarch
openoffice.org-core is needed by (installed) openoffice.org-langpack-en-1:3.1.0-3.2.fc11.i586 plymouth(system-plugin) is needed by (installed) plymouth-system-plugin-0.6.0-3.fc11.i586
jdepend is needed by (installed) jdepend-demo-0:2.6-8.4.fc11.i586
svnkit is needed by (installed) eclipse-svnkit-1.2.2-1.fc11.noarch
evolution is needed by (installed) evolution-help-2.25.92-1.fc11.noarch
Not removing old transaction files
#

  what if i try to resolve one of those manually?

# yum remove gnome-games
Loaded plugins: dellsysidplugin2, downloadonly, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package gnome-games.i386 1:2.25.5-1.fc11 set to be erased
--> Processing Dependency: gnome-games = 1:2.25.5-1.fc11 for package: gnome-games-help
--> Running transaction check
---> Package gnome-games-help.i386 1:2.25.5-1.fc11 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================
Package Arch Version Repository Size
===================================================================================
Removing:
gnome-games i386 1:2.25.5-1.fc11 installed 19 M
Removing for dependencies:
gnome-games-help i386 1:2.25.5-1.fc11 installed 20 M

Transaction Summary
===================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       2 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
gnome-games is needed by (installed) gnome-games-help-1:2.25.92-1.fc11.noarch
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])

  all right, let's take this one step at a time:

# yum remove gnome-games-help
Loaded plugins: dellsysidplugin2, downloadonly, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package gnome-games-help.noarch 1:2.25.92-1.fc11 set to be erased
---> Package gnome-games-help.i386 1:2.25.5-1.fc11 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================
Package Arch Version Repository Size
===================================================================================
Removing:
gnome-games-help noarch 1:2.25.92-1.fc11 installed 19 M gnome-games-help i386 1:2.25.5-1.fc11 installed 20 M

Transaction Summary
===================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       2 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : gnome-games-help 1/2 Erasing : gnome-games-help 2/2

Removed:
gnome-games-help.noarch 1:2.25.92-1.fc11 gnome-games-help.i386 1:2.25.5-1.fc11

Complete!
#

at which point i can simply "yum remove gnome-games".
i can see this is going to take a while if i want to salvage this
machine, unless there's a magic shortcut i don't know about.

rday






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]