[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F11 rawhide severe X11 latency problems with Radeon



Hello,

Apologies if this issue has already been discussed[1].

I decided recently to try giving Rawhide a go for my day to day
workstation. It was previously running a relatively old, but stable
version of Ubuntu.

After going through the secret initiation rituals of rpm cpio md5
madness[2], many broken dependencies[3], package file conflicts[4],
and duplicate package installs[5], I finally managed to get some
basic level of assurance[6] of a working system.

I am currently running kernel 2.6.29-0.215.rc7.fc11.x86_64. Video
card is a Gigabyte ATI Radeon X700 Pro (PCIE) (RV410). CPU is
a 2.8GHz Pentium D. 2 GB RAM. All packages are the latest (sans
WebKit-gtk and devhelp dependency problems).

Symptoms are:
1) Occasional slow (up to 4-6 seconds) redraw of windows when switching
   between virtual desktops
2) Complete freeze of mouse cursor (and rest of X) especially when
   moving a window or doing a large vertical scroll in firefox
3) Symptoms are much worse when firefox is running. Typing out this
   email (gnome-terminal & ssh) was painful with freezes and input
   getting lost.
4) (related?) glxgears or any GL will lock up X server.

I'm not sure whether this is kernel or X11 related. Any ideas on
what I can do to diagnose this further ?

[1] I just recently joined the mailing list and can't see anything
    obvious in the mail archives (*ahem* useful subject lines).  
[2] Ergh, WTF is the deal with no compatibility flag in the RPM header
    that could have been tested rather than an obscure error message ?
[3] Yay to yum --skip-broken for saving my sanity!
[4] Yay to package-cleanup --orphans and rpm -e
[5] Yay to package-cleanup --cleandupes
[6] rpm -Va && yum reinstall && find / -exec rpm -qf {} \;|grep 'not owned'

--
e


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]