[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel video testing: It worked for a bit...



Robert Arendt wrote:
Leon Stringer wrote:
After the many comments and suggestions following my post last week I
tried F11A on my Intel D845GERG2-based system.

Anaconda didn't work with the default driver (same bug as #470371 in
F10) but worked fine with the Basic Video Driver option.

First boot, black screen but setting Option "NoAccel" "true" fixed that
(using the VESA driver).

So I could get into X, set up my Wi-Fi card and download the updates.

Now it doesn't work again!

Advice and assistance gratefully received,


The xorg-x11-drv-nouveau should be irrelevant if you're using intel graphics.

Also, you should use xorg-x11-drv-intel-2.6.0-14.fc11.i586.rpm for
the latest;  Yum/rawhide changed me from -i810 to -intel at some point.
I have a intel 845G/GL[Brookdale-G] 8086:2562 rev3 on a Dell laptop.
 From yesterday's testing:
  https://fedoraproject.org/wiki/QA/Test_Days/2009-03-12

.. it appears the KMS (on by default) doesn't set up the 845G correctly.
Boot with "nomodeset" on the kernel boot line.

If the screen goes black, toggle around the VT's (clt-alt-Fn) to restore it.
With nomodeset, the text VT backlights always work.  There seems to be a
race condition in re-enabling the screen backlight with the intel Xserver.


Bob: Thanks for your reply. Unfortunately, I can't get this to work for me. I did:

  rpm -e --nodeps xorg-x11-drv-i810

then

  rpm -i xorg-x11-drv-intel-2.6.0-14-fc11.i586

And I've tried all the tests I think could possibly work:

1. Driver "intel": Screen flashes blank, then back text mode a few times before staying black, cursor in top left, system locked up. 2. Driver "intel"+nomodeset: X attempts to load, see mouse cursor briefly, then blank, system locked up 3. Driver "intel"+NoAccel: Screen flashes blank, then back text mode a few times before staying black, system locked up 4. Driver "intel"+NoAccel+nomodeset: X attempts to load, see mouse cursor briefly, then blank, system locked up, no VTs 5. Driver "intel"+XXA: Screen flashes blank, then back text mode a few times before staying black, cursor in top left, system locked up 6. Driver "intel"+XXA+nomodeset: X attempts to load, see mouse cursor briefly, then blank, system locked up, no VTs 7. Driver "vesa"+NoAccel+nomodeset: X attempts to load, see mouse cursor briefly, then blank, system locked up 8. Driver "vesa"+NoAccel: X attempts to load, see mouse cursor briefly, then blank, system locked up 9. Driver "vesa"+XXA: X attempts to load, see mouse cursor briefly, then blank, system locked up 10. Driver "vesa"+XXA+nomodeset: X attempts to load, see mouse cursor briefly, then blank, system locked up 11. Driver "vesa": X attempts to load, see mouse cursor briefly, then blank, system locked up 12. Driver "vesa"+nomodeset: X attempts to load, see mouse cursor briefly, then blank, system locked up

Some of these combinations may not make sense, but I've tried to be thorough...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]