[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can't install i586 rpm on fedora 11 x86_64 - rawhide



On Mon, Mar 16, 2009 at 23:12:15 -0400,
  Igor Miletic <grejigl-gnomeprevod yahoo ca> wrote:
> 
> When trying to install pretty much any i586 rpm I get file conflicts with
> x86_64 rpms of the same package.
> 
> For example, when installing wine, which comes only in i586 version, it
> pulls alsa-lib.i586 as well.  Installation fails due to:
> file /usr/share/alsa/cards/RME9652.conf from alsa-lib-1.0.19-3.fc11.i586
> installation is in conflict with file from alsa-lib-1.0.19-1.fc11.x86_64
> package
> 
> Am I missing something? Is there a new way to install i586 rpms on x86_64
> system, or i586 compatibility is not any more supported on Fedora 11?

There are two possibilities. One is that the i586 and x86_64 versions should
be the same, so you may need to update the x86_64 version at the same time
as you are installing the i586 version.

The other thing I think I have seen is false positives from yum where
there is a file conflict between a new and old package, even though
the old package is being replaced by another new package which doesn't
have the problem. When I saw that I had to uninstall some stuff temporarily.

I have been busy worrying about other brokenness and haven't tried to put
together a reproduceable test case for the yum guys to look at.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]