[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: More on high i/o load wedging Fedora 10



Eric Sandeen wrote:
Robin Laing wrote:
Eric Sandeen wrote:
Chuck Forsberg WA7KGX N2469R wrote:
I reformatted the backup drive with ext2 to see if that made any
difference.  Fedora still wedged during the backup, twice.
When/if you gather the info I requested - sysrq 'w' output, which will
actually help identify & resolve the issue instead of speculating about
it, please file a bug against the kernel, attach the info I asked for,
and I'll see it that way.  I probably won't be following these threads
further.

-Eric

And when you do, post the details to this list.

I ask that as my F10 machine is going into a total freeze during backups as well. The only item of what happened was a message in messages about a kernel oops.

What is the number for the bug you filed?

I thought it may be related to the EXT4 issues and I am in the process of dumping EXT4 after reading many reports of data loss.

Please don't.  Please at *LEAST* report the bug(s) first - with details.

Guys, reporting vague errors on this list and then not following up with
any useful information - especially when specific, simple steps are
requested from developers who could *fix* it - is just wasting people's
time and bandwidth.

For what it's worth, I assume your "many reports of data loss" are
probably related to the recent slashdot/lwn/launchpad/whatever posting.

I won't rehash all the details of that, but patches are now in f10 and
f11 to make ext4 behave a bit more like ext3, even when applications
aren't doing an fsync(); on their data.  I do not expect that you will
be at a large risk of data loss with ext4 on Fedora.

Thanks,
-Eric



I always will report bugs if I can get the details. It is almost useless to report bugs if you don't have any details to post with it as there is a request for more details.

It takes time to learn what tools to use to find issues. I just read an IBM paper on tracing problems using iostat. I also found dstat at the same time. It is IO related as the problems all come from using or writing to a hard drive. It has also gotten worse and may be related to the latest kernel.

My dumping EXT4 is more due to reports that I have read about data loss due to the procedure for write delays. I have run into the issue of losing my kde config files as reported by others on the net already.

http://www.advogato.org/person/mjg59/diary/195.html
http://www.h-online.com/open/Possible-data-loss-in-Ext4--/news/112821
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/317781?comments=all

I am also dumping EXT4 as I am trying to trace the issue with locking/freezing computer and I don't need data losses.

As it stands, I did get a kernel oops last night that didn't crash my system and was logged in messages. I was using a tty session so this could be why the system didn't totally freeze.

I have not had time to look through it and to see where it should be posted. It is related to USB as it occurred when I unplugged my USB drive that I was restoring data from. It was late and I was tired so I want to check things on the system before going further.

There is an issue with filing kernel related bugs if the kernel is tainted because of Nvidia drivers. I have been told before that I need to remove the driver before filing a bug. Well that is hard to do when 3D is needed on the computer with the problem.

I just tried the sysrq 'w' but I don't have that command on my machine at work.



--
Robin Laing


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]