[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can't install i586 rpm on fedora 11 x86_64 - rawhide





On Tue, Mar 17, 2009 at 7:03 PM, Kevin Kofler <kevin kofler chello at> wrote:
Igor Miletic wrote:
> For example, when installing wine, which comes only in i586 version, it
> pulls alsa-lib.i586 as well.  Installation fails due to:
> file /usr/share/alsa/cards/RME9652.conf from alsa-lib-1.0.19-3.fc11.i586
> installation is in conflict with file from alsa-lib-1.0.19-1.fc11.x86_64
> package

The version doesn't match, the alsa-lib.i586 you're trying to install is
newer. You have to "yum update" before installing new stuff.
 
Yes, this was one of problems. I had unfinished transaction when rpm was updated to 4.7. Because of that yum/rpm thought that I had installed both new version of alsa-lib (and many other packages) and old one. This is reason why I was unable to install 586 packages. There weren't actually any duplicates, I think that rpm database was not cleared properly.

Well, yum-complete-transaction cleared that problem by removing pretty much every package on my test system :), including glibc. This is probably bug/feature that I should report against yum.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]