[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Rawhide upgrade problems



Hi everyone,

Please let me know if the following was done right and what can I do to get to rawhide. I installed f10 from DVD, updated it fully, then changed the software sources from f10 to rawhide, did a yum update rpm\* (rpmlint failed to update with the following error:

[arares localhost ~]$ sudo yum update rpm\*
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package rpmlint.noarch 0:0.85-4.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Updating:
rpmlint noarch 0.85-4.fc11 rawhide 191 k

Transaction Summary
================================================================================
Install 0 Package(s) Update 1 Package(s) Remove 0 Package(s)
Total size: 191 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : rpmlint 1/2
Error unpacking rpm package rpmlint-0.85-4.fc11.noarch
error: unpacking of archive failed on file /etc/bash_completion.d/rpmlint;49c672d2: cpio: MD5 sum mismatch

Updated:
rpmlint.noarch 0:0.85-4.fc11
Complete!
)
, then tried a yum update, which fails with Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libxkbfile.so.1()(64bit) is needed by xorg-x11-xkb-utils-7.2-8.fc11.x86_64
libtirpc.so.1()(64bit) is needed by rpcbind-0.1.7-2.fc11.x86_64
libbabl-0.0.so.0()(64bit) is needed by gegl-0.0.22-3.fc11.x86_64
libungif.so.4()(64bit) is needed by libgdiplus-2.4-2.RC1.fc11.x86_64
rpm is needed by yum-3.2.21-16.fc11.noarch
rpm-python is needed by yum-3.2.21-16.fc11.noarch
rpm-python is needed by rpmlint-0.85-4.fc11.noarch
libcurl.so.4()(64bit) is needed by git-1.6.2-1.fc11.x86_64
libdaemon is needed by avahi-0.6.24-2.fc11.x86_64
libdaemon.so.0()(64bit) is needed by avahi-0.6.24-2.fc11.x86_64
libatm.so.1()(64bit) is needed by iproute-2.6.28-3.fc11.x86_64
ca-certificates is needed by openssl-0.9.8j-8.fc11.x86_64
rpm is needed by man-1.6f-17.fc11.x86_64
rpm-python is needed by system-config-users-1.2.85-2.fc11.noarch
libgsf-1.so.114()(64bit) is needed by libwpd-0.8.14-3.fc11.x86_64
keyutils-libs-devel is needed by krb5-devel-1.6.3-18.fc11.x86_64
libcroco-0.6.so.3()(64bit) is needed by librsvg2-2.22.3-2.fc11.x86_64
libgsf is needed by librsvg2-2.22.3-2.fc11.x86_64
libgsf-1.so.114()(64bit) is needed by librsvg2-2.22.3-2.fc11.x86_64
rpm is needed by policycoreutils-2.0.62-4.fc11.x86_64
libgpgme.so.11()(64bit) is needed by pygpgme-0.1-12.20090121bzr54.fc11.x86_64 libgpgme.so.11(GPGME_1.0)(64bit) is needed by pygpgme-0.1-12.20090121bzr54.fc11.x86_64
libcurl.so.4()(64bit) is needed by jigdo-0.7.3-8.fc11.x86_64
libXRes.so.1()(64bit) is needed by libwnck-2.25.91-2.fc11.x86_64
cyrus-sasl-plain is needed by libpurple-2.5.5-1.fc11.x86_64
mono(gnome-panel-sharp) is needed by tomboy-0.13.6-2.fc11.x86_64
librpm.so.0()(64bit) is needed by deltarpm-3.4-13.fc11.x86_64
librpmio.so.0()(64bit) is needed by deltarpm-3.4-13.fc11.x86_64
ConsoleKit-x11 is needed by xorg-x11-xinit-1.0.9-5.fc11.x86_64
xauth is needed by xorg-x11-xinit-1.0.9-5.fc11.x86_64
zenity is needed by metacity-2.25.144-5.fc11.x86_64
libcurl.so.4()(64bit) is needed by transmission-1.51-1.fc11.x86_64
python-numeric is needed by pygtk2-2.14.1-1.fc11.x86_64
device-mapper-devel is needed by e2fsprogs-devel-1.41.4-5.fc11.x86_64
libxkbfile.so.1()(64bit) is needed by libxklavier-3.8-4.fc11.x86_64
libthai is needed by pango-1.24.0-1.fc11.x86_64
libthai.so.0()(64bit) is needed by pango-1.24.0-1.fc11.x86_64
libcurl.so.4()(64bit) is needed by vorbis-tools-1:1.2.0-4.fc11.x86_64
cracklib-dicts is needed by pam-1.0.91-1.fc11.x86_64
zenity is needed by gedit-1:2.25.8-1.fc11.x86_64
rpm-build is needed by rpmdevtools-7.0-2.fc11.noarch
rpm-python is needed by rpmdevtools-7.0-2.fc11.noarch
rpm-python is needed by system-config-network-tui-1.5.95-2.fc11.noarch
libcurl.so.4()(64bit) is needed by python-pycurl-7.19.0-1.fc11.x86_64
libx86.so.1()(64bit) is needed by vbetool-1.1-3.fc11.x86_64
rpm is needed by preupgrade-1.0.1-2.fc11.noarch
rpm-python is needed by preupgrade-1.0.1-2.fc11.noarch
rpm is needed by createrepo-0.9.6-12.fc11.noarch
rpm-python is needed by createrepo-0.9.6-12.fc11.noarch
libcurl.so.4()(64bit) is needed by openoffice.org-core-1:3.1.0-4.1.fc11.x86_64
libcurl.so.4()(64bit) is needed by raptor-1.4.18-2.fc11.x86_64
audit-libs-python is needed by policycoreutils-python-2.0.62-4.fc11.x86_64
tex-preview is needed by texlive-texmf-latex-2007-28.fc11.noarch
curl is needed by fedora-packager-0.3.3-1.fc11.noarch
rpm-build is needed by fedora-packager-0.3.3-1.fc11.noarch
rpm is needed by kde-filesystem-4-24.fc11.noarch
ca-certificates is needed by neon-0.28.4-1.x86_64
passwd is needed by usermode-1.99-3.x86_64
libcurl.so.4()(64bit) is needed by gnupg-1.4.9-5.fc11.x86_64
flex is needed by xmlto-0.0.21-8.fc11.x86_64
rpm-python is needed by koji-1.3.1-2.fc11.noarch
logrotate is needed by ppp-2.4.4-11.fc11.x86_64
logrotate is needed by rsyslog-3.21.10-2.fc11.x86_64
libmpfr.so.1()(64bit) is needed by cpp-4.4.0-0.23.x86_64
libcurl.so.4()(64bit) is needed by kerneloops-0.12-4.fc11.x86_64
libdaemon.so.0()(64bit) is needed by avahi-autoipd-0.6.24-2.fc11.x86_64
libbabl-0.0.so.0()(64bit) is needed by gimp-2:2.6.5-4.fc11.x86_64
audit is needed by setroubleshoot-server-2.1.6-1.fc11.x86_64
audit-libs-python is needed by setroubleshoot-server-2.1.6-1.fc11.x86_64
rpm-python is needed by setroubleshoot-server-2.1.6-1.fc11.x86_64
Not removing old transaction files

What am I doing wrong? Please help me. I couldn't install from the alpha DVD, because of the bug # 488803.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]