[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum update from F10 to rawhide



A lot of people seem to have been having trouble with using yum to update from F10 to rawhide, so I thought I would try it. My tests were as follows
1. yum update (still in F10, checking afterwards that I have at least
rpm-4.6.0-1.fc10.x86_64)
2. yum update --enablerepo=rawhide
This fails, due to a couple of packages that don't have F11 versions, the errors ending with audit-libs-python-1.7.12-3.fc10.x86_64 from installed has depsolving problems --> Missing Dependency: python(abi) = 2.5 is needed by package audit-libs-python-1.7.12-3.fc10.x86_64 (installed)
python-psycopg2-2.0.9-1.fc10.x86_64 from installed has depsolving problems
--> Missing Dependency: libpython2.5.so.1.0()(64bit) is needed by package python-psycopg2-2.0.9-1.fc10.x86_64 (installed)
python-psycopg2-2.0.9-1.fc10.x86_64 from installed has depsolving problems
--> Missing Dependency: python(abi) = 2.5 is needed by package python-psycopg2-2.0.9-1.fc10.x86_64 (installed) Error: Missing Dependency: libpython2.5.so.1.0()(64bit) is needed by package python-psycopg2-2.0.9-1.fc10.x86_64 (installed) Error: Missing Dependency: python(abi) = 2.5 is needed by package python-psycopg2-2.0.9-1.fc10.x86_64 (installed) Error: Missing Dependency: python(abi) = 2.5 is needed by package audit-libs-python-1.7.12-3.fc10.x86_64 (installed)

The problem for both of these packages (python-psycopg2 and audit-libs-python) is that F10 version > rawhide version
3. rpm -e python-psycopg2 audit-libs-python
error: Failed dependencies:
python-psycopg2 is needed by (installed) TurboGears-1.0.8-1.fc10.noarch audit-libs-python is needed by (installed) setroubleshoot-server-2.0.12-3.fc10.noarch audit-libs-python >= 1.2.6-3 is needed by (installed) setroubleshoot-server-2.0.12-3.fc10.noarch audit-libs-python >= 1.4.2-1 is needed by (installed) policycoreutils-2.0.57-17.fc10.x86_64
4. rpm -e python-psycopg2 audit-libs-python --nodeps
(Having checked by the previous command that we aren't going to break anything too important - rpm works because we haven't installed anything from rawhide yet)
5. yum update --enablerepo=rawhide --disablerepo=updates
(if we don't turn off updates the F10 versions of python-psycopg2 and audit-libs-python will try to come back and confuse things)

This ends with the error
Transaction Check Error:
package audit-libs-1.7.12-3.fc10.x86_64 (which is newer than audit-libs-1.7.12-2.fc11.i586) is already installed file /etc/libaudit.conf from install of audit-libs-1.7.12-2.fc11.i586 conflicts with file from package audit-libs-1.7.12-3.fc10.x86_64

6. rpm -e audit audit-libs --nodeps
(A bit risky, because this might break a few things, but nothing directly
related to the upgrade)

7. yum update --enablerepo=rawhide --disablerepo=updates

This works.

So it is possible to upgrade from F10 to rawhide if you are careful, and any problems are because rawhide is lagging a bit behind F10 updates, presumably because of the beta freeze.

	Michael Young


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]