[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum update from F10 to rawhide



On Mon, 23 Mar 2009, MartinG wrote:

I'm still not sure I've got everything straight, as I've got
audit-libs-1.7.12-3.fc11.x86_64.rpm from
koji, but the .i586 version was not available (and I've got a canon
printer connected to the system,
and that (crappy) driver drags along some i386/i586 stuff).
Only audit-libs-1.7.12-2.fc11.i586.rpm is available, which I had to
force in, as it is one tick behind.

Perhaps you don't need it at all. The error
Transaction Check Error:
  package audit-libs-1.7.12-3.fc10.x86_64 (which is newer than
audit-libs-1.7.12-2.fc11.i586) is already installed
  file /etc/libaudit.conf from install of audit-libs-1.7.12-2.fc11.i586
conflicts with file from package audit-libs-1.7.12-3.fc10.x86_64
shows that the dependency resolution has pulled in audit-libs-1.7.12-2.fc11.i586 but audit-libs.i586 (or .i386) can't be already installed because it would match the x86_64 version. The reason it has been dragged in will be that some package, such as audit-libs-python, says that it needs audit-libs = 1.7.12-2 but can't use audit-libs-1.7.12-2.fc11.x86_64 because the later audit-libs-1.7.12-3.fc10.x86_64 is already installed, so the dependency resolver picks audit-libs-1.7.12-2.fc11.i586 instead which does provide audit-libs = 1.7.12-2 (audit-libs-python would require x86_64 libaudit library(s) as well but these would be much less dependant on the precise package version so audit-libs-1.7.12-3.fc10.x86_64 will satisfy them).

Hence you get the audit-libs-1.7.12-2.fc11.i586 package and maybe other extra i586 packages (or you would do if it didn't conflict) when it isn't really want you want, because the dependency resolver is just doing its best to get you out of an impossible situation.

	Michael Young


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]