[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[OT?] building and installing python 3.1b1?



  for pedagogical reasons, i'd like to build and install (from
tarball) python3.1b1 on my f11 system.  since it will, by default,
install under /usr/local/lib, i should be able to do that and play
with it without breaking everything else that currently relies on
python 2.6.

  currently, after a default "./configure", when i run "make," i get:

...
Python build finished, but the necessary bits to build these modules
were not found:
_tkinter
To find the necessary bits, look in setup.py in detect_modules() for
the module's name.
...

  currently, i have the tkinter-2.6 package installed, but i'm
guessing that's not sufficient, and i probably have to download and
install (again from tarball) a compatible version of tkinter.

  help?  anyone done this?  AFAICT, the end result will still work, i
just won't have tkinter capability, and i'd like to get it.  thanks.

rday

p.s.  in any event, it will be interesting to see if those two
versions can co-exist -- 2.6 officially, and 3.1 unofficially.
--

========================================================================
Robert P. J. Day                               Waterloo, Ontario, CANADA

        Linux Consulting, Training and Annoying Kernel Pedantry.

Web page:                                          http://crashcourse.ca
Linked In:                             http://www.linkedin.com/in/rpjday
Twitter:                                       http://twitter.com/rpjday
========================================================================


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]