[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade problem



On Mon, 2009-05-18 at 22:39 -0600, Reid Rivenburgh wrote:
> Hi.  I'm currently running F10 on x86_64 and thought I'd try an
> upgrade to F11/rawhide.  I think I used preupgrade to go from F9 to
> F10, and it worked fine.  This time, it downloaded images and tons of
> packages, then died with this output:

If you're going to be doing preupgrades, please:
1) use preupgrade-1.1.0 (in updates-testing right now), and
2) don't bother going from F9->F10->F11. Just go straight to 11/Rawhide.

> ...
> Generating metadata for preupgrade repo
> Traceback (most recent call last):
>   File "/usr/share/preupgrade/preupgrade-gtk.py", line 766, in <module>
>     widgets = PreUpgradeGtk()
>   File "/usr/share/preupgrade/preupgrade-gtk.py", line 374, in __init__
>     self._do_main()
>   File "/usr/share/preupgrade/preupgrade-gtk.py", line 257, in _do_main
>     self.main_preupgrade()
>   File "/usr/share/preupgrade/preupgrade-gtk.py", line 545, in main_preupgrade
>     callback=MDGenCallback(pbar=self.progress))
>   File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line
> 651, in generate_repo
>     misc.generate_repodata(dir,comps,callback)
>   File "/usr/lib/python2.5/site-packages/preupgrade/misc.py", line
> 131, in generate_repodata
>     generate_repodata(dir, comps, callback)
>   File "/usr/lib/python2.5/site-packages/preupgrade/misc.py", line
> 147, in generate_repodata_f9
>     mdgen.doPkgMetadata()
>   File "/usr/lib/python2.5/site-packages/createrepo/__init__.py", line
> 332, in doPkgMetadata
>     self.writeMetadataDocs(packages)
>   File "/usr/lib/python2.5/site-packages/createrepo/__init__.py", line
> 472, in writeMetadataDocs
>     self.primaryfile.write(po.xml_dump_primary_metadata())
>   File "/usr/lib/python2.5/site-packages/yum/packages.py", line 1013,
> in xml_dump_primary_metadata
>     msg += misc.to_unicode(self._dump_base_items())
>   File "/usr/lib/python2.5/site-packages/yum/packages.py", line 846,
> in _dump_base_items
>     (csum_type, csum, csumid) = self.checksums[0]
> IndexError: list index out of range

That's odd. It looks like createrepo failed. But notice the
"generate_repodata_f9" line there - if your system is F10, why is it
using F9 createrepo?

Try upgrading createrepo (and preupgrade!) and try it again. You should
also update your system and run 'package-cleanup --problems' to make
sure your system has the right packages. The old preupgrade (1.0.x)
didn't install updates etc. so it sometimes fails to upgrade packages
that need upgrading.

> There were also many dependency line like this before the above output:
> 
> 1:qt-x11-4.5.1-10.fc10.i386 from installed has depsolving problems
>   --> Missing Dependency: libcrypto.so.7 is needed by package
> 1:qt-x11-4.5.1-10.fc10.i386 (installed)

These are non-fatal - please ignore them.

> I have picasa 3.x installed, and probably some other external
> packages; could they be causing the crash?  

Possibly. It looks like createrepo is having trouble handling some
non-UTF8 data from some of your packages. Probably your createrepo
package is old and just a bit buggy. 

If you were using preupgrade-1.1.0 it could possibly be due to
misbehaving packages in a third-party repo. But you didn't mention that,
so it's probably not the problem.

> If preupgrade doesn't 
> work, I may either try to upgrade via yum after release or burn a
> disk.  TIA!

Please, do yourself a favor and do *not* yum upgrade. 

If you decide to ignore me and do it anyway, do *NOT* run yum from a
terminal in X. Run it in a 'screen' session, or from a virtual terminal,
or something like that. If the terminal crashes mid-upgrade - and there
are known bugs that will cause that! - your system will be a broken
half-upgraded mess of duplicate and/or missing packages.

Seriously. Yum upgrades on a running system are not safe. Be very
careful with them.

-w


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]