[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

distutils working only with python-devel



When you try to use distutils to install python module or
application, you receive a following error:

# python setup.py install
running install
error: invalid Python installation: unable to open /usr/lib64/python2.6/config/Makefile (No such file or directory)
#

The problem is that you don't have python-devel package
installed. My question is - is that right? Why should a 
common user install devel packages to be able to install
python apps? Not mentioning cryptic error message (not
everyone will guess that).

Similar problem is for easy_install, it is located in the
python-setuptools-devel package.

I have looked at Ubuntu, the no problems there, everything
needed in non-devel packages.

Thanks for comments.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]