[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: any life-threatening danger in upgrading my f11 box to rawhide?



On Sun, 8 Nov 2009, Adam Williamson wrote:

> On Sun, 2009-11-08 at 16:35 -0500, Robert P. J. Day wrote:
> > On Sun, 8 Nov 2009, Adam Williamson wrote:
> >
> > > including a specific section for f11->f12:
> > >
> > > https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_11_-.3E_Rawhide_.28Fedora_12.29
> >
> >   that looks doable -- i already have the necessary version of rpm, so
> > it looks like:
> >
> >   # yum --enablerepo=rawhide --skip-broken upgrade
> >
> > that's it, is it?
>
> get behind the blast shelter and give it a whirl =)

  *huge* number of missing dependencies and unresolvable requirements.
i tried that command with --downloadonly to play it safe, but got
loads of output like:

...
  --> Unresolvable requirement udev for mdadm-3.0-1.fc11.x86_64
(installed)
pcmciautils-015-2.fc11.x86_64 from installed has depsolving problems
  --> Unresolvable requirement udev >= 062 for
pcmciautils-015-2.fc11.x86_64 (installed)
hal-0.5.12-29.20090226git.fc11.x86_64 from installed has depsolving
problems
  --> Unresolvable requirement udev >= 089-1 for
hal-0.5.12-29.20090226git.fc11.x86_64 (installed)
libdrm-2.4.11-2.fc11.x86_64 from installed has depsolving problems
  --> Unresolvable requirement udev for libdrm-2.4.11-2.fc11.x86_64
(installed)
linuxwacom-0.8.2.2-11.fc11.x86_64 from installed has depsolving
problems
  --> Unresolvable requirement udev >= 030-21 for
linuxwacom-0.8.2.2-11.fc11.x86_64 (installed)
1:NetworkManager-0.7.1-8.git20090708.fc11.x86_64 from installed has
depsolving problems
  --> Missing Dependency: libpolkit.so.2()(64bit) is needed by package
1:NetworkManager-0.7.1-8.git20090708.fc11.x86_64 (installed)
pulseaudio-0.9.15-17.fc11.x86_64 from installed has depsolving
problems
  --> Missing Dependency: libpolkit-dbus.so.2()(64bit) is needed by
package pulseaudio-0.9.15-17.fc11.x86_64 (installed)
libmtp-0.3.7-2.fc11.x86_64 from installed has depsolving problems
  --> Unresolvable requirement udev for libmtp-0.3.7-2.fc11.x86_64
(installed)
libdrm-2.4.11-2.fc11.x86_64 from installed has depsolving problems
  --> Unresolvable requirement udev for libdrm-2.4.11-2.fc11.x86_64
(installed)
1:NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64 from installed has
depsolving problems
  --> Missing Dependency: libnm_glib.so.0()(64bit) is needed by
package 1:NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64 (installed)
1:NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64 from installed has
depsolving problems
  --> Missing Dependency: libnm_glib_vpn.so.0()(64bit) is needed by
package 1:NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64 (installed)
DeviceKit-power-010-0.3.20090810git.fc11.x86_64 from installed has
depsolving problems
  --> Missing Dependency: libpolkit-dbus.so.2()(64bit) is needed by
package DeviceKit-power-010-0.3.20090810git.fc11.x86_64 (installed)
pulseaudio-0.9.15-17.fc11.x86_64 from installed has depsolving
problems
  --> Missing Dependency: libpulsecommon-0.9.15.so()(64bit) is needed
by package pulseaudio-0.9.15-17.fc11.x86_64 (installed)
...

  it just went on and on, although this was printed at the end:

 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

is that what i want to try?

rday
--

========================================================================
Robert P. J. Day                               Waterloo, Ontario, CANADA

            Linux Consulting, Training and Kernel Pedantry.

Web page:                                          http://crashcourse.ca
Twitter:                                       http://twitter.com/rpjday
========================================================================


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]