[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: any life-threatening danger in upgrading my f11 box to rawhide?



On Sun, Nov 08, 2009 at 19:34:32 -0500,
  "Robert P. J. Day" <rpjday crashcourse ca> wrote:
> 
>   as a single example, my attempt to upgrade produced:
> 
>   --> Missing Dependency: libssl.so.8()(64bit) is needed by package
> tigervnc-server-1.0.0-2.fc11.x86_64 (installed)
> 
>   if i read the situation correctly, openssl would be upgraded but
> there *is* no newer version of tigervnc-server in rawhide, so the
> current version would remain, with its dependency on the older (and
> about to be replaced) version of openssl.  hence, the dependency
> failure.  is that an accurate description of what is happening here?
> 
> rday
> 
> p.s. in fact, there is no package named "tigervnc-server" in f12 at
> all, just tigervnc.

How are you checking? tigervnc-server-1.0.0-1.fc12.i686 is installed on
my machine. Looks like this is a case of the F11 updates version having
a higher release number than the F12 version. Because it blocks the ssl
update that's going to cause a mess. The easiest solution is to remove it
before the update and then reinstall it afterwards. If you do the update
in a yum shell you can probably avoid erasing it for a while, but it
may be simpler for a package without a lot of dependencies to erase it.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]