[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: preupgrade attempt from f11 box to rawhide?



On 11/09/2009 08:28 AM, Adam Williamson wrote:
upgrading via yum is not really supported - preupgrade is preferred -
I am seeing the same issue with preupgrade (tigervnc-f12 !> tingervnc-f11):
=====
...
treeinfo timestamp: Sun Nov  8 00:10:34 2009

akmod-VirtualBox-OSE-3.0.8-1.fc12.i686 from preupgrade-rpmfusion-free-rawhide has depsolving problems --> Missing Dependency: VirtualBox-OSE-kmodsrc = 3.0.8 is needed by package akmod-VirtualBox-OSE-3.0.8-1.fc12.i686 (preupgrade-rpmfusion-free-rawhide)
tigervnc-server-1.0.0-2.fc11.i586 from installed has depsolving problems
--> Missing Dependency: libssl.so.8 is needed by package tigervnc-server-1.0.0-2.fc11.i586 (installed)
tigervnc-server-1.0.0-2.fc11.i586 from installed has depsolving problems
--> Missing Dependency: libcrypto.so.8 is needed by package tigervnc-server-1.0.0-2.fc11.i586 (installed)

Downloading 954.6MB
Available disk space for /var/cache/yum/preupgrade: 2.5GB
Setting up and reading Presto delta metadata
unknown metadata being downloaded: 7bc38af3d93975224acb85cd842
...
=====
# yum --enablerepo=rawhide update tiger\*
Loaded plugins: allowdowngrade, downloadonly, presto, refresh-packagekit
Setting up Update Process
No Packages marked for Update
=====
yum --enablerepo=rawhide list tiger\*
Loaded plugins: allowdowngrade, downloadonly, presto, refresh-packagekit
Installed Packages
tigervnc.i586                1.0.0-2.fc11  @updates
tigervnc-server.i586         1.0.0-2.fc11  @updates
Available Packages
tiger.i586                   3.2.1-10.fc11 fedora
tiger.i686                   3.2.1-11.fc12 rawhide
tigervnc.i686                1.0.0-1.fc12  rawhide
tigervnc-server.i686         1.0.0-1.fc12  rawhide
tigervnc-server-module.i686  1.0.0-1.fc12  rawhide
tigervnc-server-module.i586  1.0.0-2.fc11  updates
=====
$ rpmdev-vercmp 1.0.0-2.fc11 1.0.0-1.fc12
0:1.0.0-2.fc11 is newer

So, it appears that either the release must get a bumped to at least -2 version, or we are going to need a release note to try to explain our way out of this one ?

I'll have to wait and see if the preupgrade download and upgrade process suceeds (might take some days here).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]