[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: upgrading f11 -> rawhide



On Tue, 10 Nov 2009, Rahul Sundaram wrote:

> On 11/10/2009 02:47 AM, Seth Vidal wrote:
>
> > but if you find situations where it cannot work, report them - I
> > can probably explain if it is likely an insurmountable situation
> > where preupgrade/anaconda is required or whether it is a packaging
> > issue or just a yum bug.
>
> Yes, in very large majority of cases, the failures are solvable. It
> just requires MORE people to do it and report problems combined with
> some automated QA. Some of the corner cases are hard or impossible
> to solve but I do encourage people with some amount of time to
> please try and report issues.  Recommending a preupgrade or even a
> clean install is OK but I would like to see a overall better upgrade
> experience.

  just FYI, i wasn't expecting perfection -- there was some software i
wanted to test specifically under F12, so i was willing to take a
chance and mess up my system (to some extent), knowing that it would
be easy enough to recover and that the real F12 was just around the
corner; hence, caution to the winds and an upgrade.

  trying to do it a chunk at a time ran into the occasional glitch:

https://bugzilla.redhat.com/show_bug.cgi?id=533925

but even after resolving that, the resulting system couldn't start the
X server, leaving me high and dry.  so ... in with the F12 Beta DVD
and tell it to upgrade existing system, go away for coffee, come back
and ... looks good.

  networking running, wireless working, video actually at full res of
1280x800 with radeon driver ... sweet.

  some interesting observations in /var/log/messages:

Nov 10 03:43:55 localhost abrtd: Hmm, stray update_client: 'Creating kernel oops crash reports...'
Nov 10 03:43:55 localhost abrt: Kerneloops: Reported 1 kernel oopses to Abrt
Nov 10 03:43:55 localhost abrtd: Directory 'kerneloops-1257842635-1' creation detected
Nov 10 03:43:55 localhost abrtd: Hmm, stray warn_client:
'CPluginManager::GetDatabase():Database plugin: 'SQLite3' is not
registered.'

but i'll worry about those later.

  i'm still going to do a fresh F12 install when it arrives.

rday
--


========================================================================
Robert P. J. Day                               Waterloo, Ontario, CANADA

            Linux Consulting, Training and Kernel Pedantry.

Web page:                                          http://crashcourse.ca
Twitter:                                       http://twitter.com/rpjday
========================================================================


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]