[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with smolt.master-smoon.messages.po (F12)



Le Thu, 17 Dec 2009 09:41:19 -0300,
Domingo Becker <domingobecker gmail com> a écrit :

> 
> 2009/12/17 Sam Friedmann <sfriedma redhat com>:
> >
> > #: hardware/templates/deviceclass.html:19
> > #, python-format
> > msgid "% hosts detected ${type}"
> > msgstr "% hôtes détectés ${type}"
> >
> > Looking for a solution, I have tried to add a second percentage
> > sign, or the letter "s" but nothing changed. I eventually looked
> > through old emails and noticed that there has been some discussions
> > about the same problem but it seems that there is no solution yet -
> > unless if I overlooked one of the emails.
> > Does anyone have an idea about what could be done ?
> 
> There seems to be a problem in the gettext library, in the way it
> takes the format string.
> The string comes from a line in deviceclass.html in smolt-server
> package: <th valign="top" width="25%">${_("% hosts detected ")}
> ${type}</th> so the string is wrongly extracted. I think it should be
> msgid "% hosts detected"
> 
> Probably filing a bug against gettext would solve the problem.
> Later, all the translations tools would have to be rebuilt again,
> which I guess it's something that would take a long time.
> 
> Another faster solution would be to ask the developer to change that
> string to something that doesn't confuse gettext library.
> I tried that for another package [1] but the developer refused to
> change it.
> 
> As said before, the string is used in the smolts web server, in an
> html template to produce an output like [2].
> But let's face the true: the site is not currently using our
> translations! or it doesn't detect properly the selected language in
> my firefox under Fedora 12 and Fedora 11.
> 
> To solve the problem, for the Spanish translation we used
> 
> msgid "% hosts detected ${type}"
> msgstr "% hosts detectados ${type}"
> 
> and then, we were able to upload the file.
> 
> But somebody has to file that bug against gettext package.
> 
> [1] https://bugzilla.redhat.com/show_bug.cgi?id=523437
> 
> [2] http://www.smolts.org/static/stats/by_class_VIDEO.html
> 
> kind regards
> 
> Domingo Becker (es)

If you open a po file in text editor with syntax highlighting , you can
see that "% ho" is considered as a macro and that is the issue. You
change the space for a unbreakable one in the .pot and it will work :) 

Pablo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]