[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 171510] k3b's Preserve file permissions (backup) option doesn't preserve directory permissions



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: k3b's Preserve file permissions (backup) option doesn't preserve directory permissions


https://bugzilla.redhat.com/show_bug.cgi?id=171510


grdetil scrc umanitoba ca changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Status Whiteboard| bzcl34nup                  |bzcl34nup
            Version|6                           |rawhide
               Flag|                            |needinfo?




------- Additional Comments From grdetil scrc umanitoba ca  2008-04-04 13:16 EST -------
I have confirmed the problem still exists in Fedora rawhide's k3b-1.0.4-6.fc9,
as well as in RHEL 5's k3b-0.12.17-1.el5.  This can be confirmed either by
burning a Data CD or Data DVD project, or by simply creating an ISO image from
K3b.  In the latest version of k3b, you can get to the "Preserve file
permissions (backup)" option by clicking the "Custom..." button under the
Filesystem tab of the Data Project dialog box.

Rawhide's mkisofs is implemented by genisoimage (version 1.1.6-11.fc9), which
has the same limitation in its implementation of the -graft-point option as
earlier versions of mkisofs (such as mkisofs-2.01-10 in RHEL 5).  The man page
for mkisofs on either rawhide or RHEL 5 also confirms this limitation -- it
creates the graft point directories with mode 0555 by default, rather than
preserving the mode of the original directories.  As a workaround, I set
-new-dir-mode 0775 in the mkisofs user parameters in K3b's configuration, which
works for our purposes, but isn't as ideal as K3b/mkisofs preserving the
original directory modes.

The original discussion of this bug in K3b on the KDE bugs site, at
http://bugs.kde.org/show_bug.cgi?id=83617 included a patch for mkisofs, from
Chris Burghart, which solved the last part of this problem (the first part
having been fixed by Sebastian Trueg in the K3b source).  But this patch has
still not made its way into the upstream mkisofs source.  Maybe the cdrkit.org
maintainers of genisoimage will be more receptive to this fix than the
maintainer of the cdrecord/cdrtools source was.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]