[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 249573] Shift with some Function Keys no longer work



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Shift with some Function Keys no longer work


https://bugzilla.redhat.com/show_bug.cgi?id=249573





------- Additional Comments From mike cchtml com  2008-06-24 17:13 EST -------
It seems that there needs to be some straightening out of the Xterm spec.
Someone (I didn't go look to see who) made a #if define around an area and seems
to have forgotten about it. Well this was the cause of the problem.

Looking at the source for vte-0.16.13/src/keymap.c:1440 and below, there is a
#if 1 define. The #if'd statement has a comment that states "Stuff a "1", a
semicolon and the modifier in right before that last character, matching Xterm."
while the old code that actually matches Xterm states "Stuff the modifier in
right before that last character, matching what people expect." After removing
the #if 1 defined code, leaving the old code, and recompiling the RPM everything
works normally and according to the xterm spec.

If anyone has a source for the reason behind this change I'd love to see it, as
the current code goes against the xterm spec as I know it. Otherwise, please
remove the #if 1 defined area. I will make a patch if I must, but it's an easy 6
line removal. I will also pursue upstream if I must (but this appears to be
upstream to begin with).

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]