[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] virt-viewer windows port

On Fri, Sep 25, 2009 at 11:57:35AM +0530, anuj rampal wrote:
> Then i tried on my windows machine
> URI that i used:
> virt-viewer.exe -c qemu://FC11-KVM/session 2
> and this is the result that i got:
> 11:35:01.672: debug : initialise_gnutls:1099 : loading CA file
> /usr/i686-pc-ming
> w32/sys-root/mingw/etc/pki/CA/cacert.pem
> 11:35:01.677: debug : initialise_gnutls:1112 : loading client cert and key
> from
> files /usr/i686-pc-mingw32/sys-root/mingw/etc/pki/libvirt/clientcert.pem and
> /us
> r/i686-pc-mingw32/sys-root/mingw/etc/pki/libvirt/private/clientkey.pem
> 11:35:01.697: debug : do_open:1017 : driver 2 remote returned ERROR
> 11:35:01.698: debug : virUnrefConnect:232 : unref connection 0263B068 1
> 11:35:01.700: debug : virReleaseConnect:191 : release connection 0263B068
> unable to connect to libvirt qemu://FC11-KVM/session

So the problem is that as you can see from reading the messages, it
can't load the client key file (from

This path is compiled into libvirt, so the only way to change it is to
recompile libvirt with sysconfdir set to a more suitable path:

  ./configure --sysconfdir=/etc

for example (and create /etc/pki ... on Windows).

> tried with different URI on windows:
> virt-viewer.exe -c qemu+tcp://FC11-KVM/session 2

This worked, obviously because it's not using GnuTLS for encryption.


Richard Jones, Emerging Technologies, Red Hat  http://et.redhat.com/~rjones
libguestfs lets you edit virtual machines.  Supports shell scripting,
bindings from many languages.  http://et.redhat.com/~rjones/libguestfs/
See what it can do: http://et.redhat.com/~rjones/libguestfs/recipes.html

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]