[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[fedora-virt] using kqemu with fedora-virt-preview repo

I have a powerful server but without VT capabilities, where I would like to use virt-manager tools as of fedora-virt-preview repo and speed up somehow things using kqemu.
It seems that kqemu support is not compiled in for this repo, correct?
Instead, as the kqemu kernel module is in rpmfusion, I presume that the stock f11 qemu has this support built in....
Am I wrong?
Any problems to compile kqemu support ?

On another server, tried to rebuild qemu-0.11.0-2.fc11.src.rpm  (from fedora-virt) after installing kqemu from rpmfusion.
But while if I take the source I get kqemu as enabled in configure script, in rpmbuild I don't get so.
I notice that inside the qemu tar.gz as provided by the source.rpm there are three lines below in the top configure script: 

if [ "$cpu" = "i386" -o "$cpu" = "x86_64" ] ; then
    audio_possible_drivers="$audio_possible_drivers fmod"

So I commented out the kqemu="no" line... and built the package (not touching the other two configure scripts that seems related to kvm...)
After installing, if I run qem-kvm or qemu without kqemu all is ok.
Instead, running
[root tekkaman bin]# ./qemu --enable-kqemu
I get
Not enough memory (requested_size = 16777216, max memory = 146800640)

Any hints?
For Kqemu now gplv2, are there any barriers to have it included in fedora directly?

Thanks in advance,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]