[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-xen] Latest Xen RPMS testing in FC5.



Hi all,

We have done a fuller testing for latest Xen updates on FC5.

Brief results:
In IA32 platform VMX/XenU/Xen run well without any problem.
But in x86_64 platform destroy VMX domain will hang Xen0. The serial port output is put in attachment. (I will report a Bug to bugzilla)


The detailed testing results:
--------
IA32
--------
Xend start                                     pass
Xm destroy                                    pass
2.4 vmx domain creating with 128M memory       pass
2.6 vmx domain creating with 256M memory       pass
2.4 vmx domain creating with 512M memory       pass
xenU domain creating                          pass
VMX and xenU coexit                           pass
2 VMXs and 2 XenUs coexist                    pass
4 VMXs coexist                                pass 
VMX Xwindows testing                         pass
Boot up a Windows domain                     pass

-------
X86_64
--------
Xend start                                    ok
Create VMX                                  ok
Destroy VMX                                 Fail. Hang Xen0.
Create and destroy XenU                      pass

================================
Environments:

The base FC5 environment is FC5-test3.
--------------------
The Xen RPMs are: 
IA32:
kernel-xen0-2.6.15-1.2025_FC5.i686.rpm kernel-xenU-2.6.15-1.2025_FC5.i686.rpm
xen-3.0.1-2.i386.rpm

kernel-xen0-2.6.15-1.2032_FC5.i686.rpm kernel-xenU-2.6.15-1.2032_FC5.i686.rpm
xen-3.0.1-3.i386.rpm

x86_64:
kernel-xen0-2.6.15-1.2025_FC5.x86_64.rpm
kernel-xenU-2.6.15-1.2025_FC5.x86_64.rpm
xen-3.0.1-2.x86_64.rpm

kernel-xen0-2.6.15-1.2032_FC5.x86_64.rpm
kernel-xenU-2.6.15-1.2032_FC5.x86_64.rpm
xen-3.0.1-3.x86_64.rpm
=================================

Other issue:

Sometime when Xen0 boot, udev will be failed to start up. It will report time out and kernel bugs.

Best Regards,
Yongkang (Kangkang) 永康

(XEN) Assertion '(pg[i].u.inuse.type_info & PGT_count_mask) == 0' failed, line c
(XEN) BUG at page_alloc.c:616
(XEN) ----[ Xen-3.0.0    Not tainted ]----
(XEN) CPU:    0
(XEN) RIP:    e010:[<ffff830000117d19>]************************************
(XEN) ----[ Xen-3.0.0    Not tainted ]----
(XEN) CPU:    0
(XEN) RIP:    e010:[<ffff8300001236c2>] number+0xc/0x38d
(XEN) RFLAGS: 0000000000010292   CONTEXT: hypervisor
(XEN) rax: 0000000000000020   rbx: 000000000000e010   rcx: 0000000000000010
(XEN) rdx: 00000000000002d7   rsi: ffff8300801f3286   rdi: ffff8300001f329b
(XEN) rbp: ffff8300001f3058   rsp: ffff8300001f2fa8   r8:  00000000ffffffff
(XEN) r9:  00000000ffffffff   r10: ffff8300801f3286   r11: ffff8300001f329b
(XEN) r12: ffff830000117d19   r13: ffff880004176810   r14: 0000000000000001
(XEN) r15: ffff880009447e78   cr0: 000000008005003b   cr3: 0000000003101000
(XEN) ds: 0000   es: 0000   fs: 0000   gs: 0000   ss: e018   cs: e010
(XEN) Xen stack trace from rsp=ffff8300001f2fa8:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]