[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] Unable to reboot a domU



Well, I used a DRBD block device, so the -oloop mount option won't work to mount my image. Oddly, I can't seem to mount the block device either. Perhaps that's my real problem? (Though why it worked the first time....?)

Anyway, my xen config file looks like this:

# Automatically generated xen config file
name = "mail"
memory = "512"
disk = [ 'phy:/dev/drbd2,xvda,w', 'phy:/dev/VolGroup00/ mailSwap,xvdb,w' ]
vif = [ 'mac=00:16:3e:75:d2:20' ]
bootloader="/usr/bin/pygrub"
on_reboot   = 'restart'
on_crash    = 'restart'

... where /dev/drbd2 is the DRBD block device holding both /boot/ and /. If I use fdisk to get a listing on /dev/drbd2, I see:

Disk /dev/drbd2: 31.4 GB, 31474057216 bytes
255 heads, 63 sectors/track, 3826 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

      Device Boot      Start         End      Blocks   Id  System
/dev/drbd2p1   *           1          13      104391   83  Linux
/dev/drbd2p2              14        3826    30627922+  8e  Linux LVM


So it *seems* like I should be able to mount /dev/drbd2p1 or /dev/ drbd2p2. Alas:

# mount /dev/drbd2p1 /mnt
mount: special device /dev/drbd2p1 does not exist

# mount /dev/drbd2p2 /mnt
mount: special device /dev/drbd2p2 does not exist

I'd be happy to blame this on DRBD, but this did work for both install and after the first reboot....

On Mar 15, 2006, at 6:19 PM, You, Yongkang wrote:

-----Original Message-----
From: fedora-xen-bounces redhat com
[mailto:fedora-xen-bounces redhat com] On Behalf Of Ben
Sent: 2006年3月16日 10:09
To: fedora-xen redhat com
Subject: [Fedora-xen] Unable to reboot a domU

I installed a domU on x86_64 today, and was very happy. I even logged
into it and saw that things seemed to be working, and all was well. I
tried to reboot it, and now the domU kernel panics every time I try
to boot. :(

So at present you couldn't create XenU with that image again? I think maybe your XenU image is broken.

Maybe you can do a manually mount that image file and check if /etc/ fstab is there.
mount -oloop xenU_image_file /mnt


The bug is 185603, and the console end with:

no fstab.sys, mounting internal defaults
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
Kernel panic - not syncing: Attempted to kill init!




Best Regards,
Yongkang (Kangkang) 永康



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]