[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-xen] Re:FC6+xen guest boot issue



Karl,

I was in the same spot you are in a couple of days ago. The problem you mention is because you don't have an initrd to tell the kernel what to mount after the kernel boots up.

The trick I found is when you make the initrd to use these extra options
#  mkinitrd --with=xennet --preload=xenblk /boot/$KERNEL-$DOMNAME.img $KERNEL

I found these instructions to work out pretty well for building an image ( http://fedoraproject.org/wiki/FedoraXenQuickstart#head-d8c5e7b0f9f95e248fbcb12e26f2e9c3b33f3dbc), except the writer does not use initrd. I don't understand how that works. But I followed the instructions and made an initrd and copied it to my host /boot and then put this line in the xen user config file and it worked for me:

ramdisk = "/boot/initrd-2.6.18-1.2798.fc6xenU.img"

Since you dont have an internet connection, you could copy the files from the RH7.3 cd's to your drive and then start apache on your local computer. I don't know if 7.3 works with yum, it has been ages since I used that version. You could then make your own yum conf with
$HOSTIP  = the ip address of your host computer
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
exclude=*-debuginfo
gpgcheck=0
obsoletes=1
reposdir=/dev/null

[base]
name=Fedora Core 4 - $basearch - Base
mirrorlist=http://$HOSTIP/mirrors
enabled=1

[updates-released]
name=Fedora Core 4 - $basearch - Released Updates
mirrorlist=http://$HOSTIP/mirrors
enabled=1
Then make a file called mirrors and in it, something like
http://$HOSTIP/RH7.3/
Then install like that doc describes....

yum -c http://$HOSTIP/yum-xen.conf --installroot=/mnt -y groupinstall Base

A few questions
What do you have in your /xen/test.img? Is something preloaded there?
Why RH 7.3? Or should I not ask.

If that doesn't work out for you. I am working on doing a normal install to a Qemu image and then converting the image to a xen bootable image. After I work that out, you might be able do the same with RH7.3

-Alex B
Disclaimer: If anything I say is wrong, it is only my interpretation of the information I had at the time.


From: Karl Stevens < karl athabascau ca>
Subject: [Fedora-xen] FC6+xen guest boot issue
To: fedora-xen redhat com
Message-ID: < 454B9E04 9070705 athabascau ca>
Content-Type: text/plain; charset=ISO-8859-1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi All,

I'm trying to set up Xen using FC6 as dom0, and am having zero success
getting any guest OS to run.

I've read the quickstart guide, but it's of little use because it makes
two very large assumptions:

1. I want to install FC6 as a guest.
2. The hardware has internet access.

I want to have RH7.3 running as a guest (but I'll settle for *anything*
right now), and the machine I want to install on is behind a firewall,
and has no internet access at all.

I've tried the Documentation at xensource.com, and even tried
downloading images from jailtime.org - no matter what I do, I encounter
the following error:

VFS: Cannot open root device "sda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on
unknown-block(0,0)

(I've tried both hda1 and sda1 as root, neither one works.)

The xen config I'm using is as follows:

kernel = "/boot/vmlinuz-2.6.18-1.2798.fc6xen"
memory = 256
name = "test"
vif = [ '' ]
disk = ['file:/xen/test.img,sda1,w',
'file:/xen/test.swap,sda2,w']
root = "/dev/sda1 ro"

The file /xen/test.img exists, is not mounted by dom0, and contains a
linux system (verified via mount -o loop, and umounted before I try to
run xm create.)
According to the Xen documentation, I believe this should work.

Is there a fc6-specific initrd that I need?  Is there any documentation
that might provide some insight on installing non-FC6 guests onto a FC6
dom0?

Thanks,
Karl

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]